Can't delete files on m240 /No Files

I’ve been trying to delete my songs on my m240, but the thing is I can’t and when I unplugge the m240 from the computer it says “No Files”, WTF?
The files show up the computer but they don’t show up in the device, I try to delete the files, and the files appear to be deleted, but when I unplug the device and plug it back in the files are still there!!!  And yes it’s in MSC mode, what gives?!  I’ve even tried formating and the computer fails to format it!

Try to format the device in device manager… Just simple right click the the computer icon and select manage… A new window will open. On the left side of the window you will see “disk management” select that and on the right side you will see your MP3 player. Single right click on it and it will force the device to format. NOTE: formatting will erase all the files on the device.

OK I did that and it tells me that the format did not complete successfully. WTF!  I dont know what to do. Any ideas?

Message Edited by Black_Talon on 02-21-2008 04:36 PM

Some help would be nice guys.

I am having the exact same problem with my m250.  My computer can see the files, but when I disconnect it from my computer, the m250 says it has nothing on it.  I am not sure what happened.

Same here on my m230.  Do these players all self-destruct by leap year?

Oh I found the instructions!

And it worked!!!  I’m back in busuness!


Message Edited by kmrsy on 02-26-2008 03:32 PM

if you are unable to format the player, im pretty sure that means its defective. If your still in that year warranty, give sandisk an email @ Theres even a sticky with all you need to contact them at the top.