Disk on key partially recognized


First of all I’m sorry if this question has been asked, its just that its very to search for a problem like this.

I own a Sandisk Ultra 16GB DOK for more than 6 months I believe. Yesterday I plugged it in my PC but it caused problems: at first the drive did not show up, after that it did show up but I couldn’t see any of my data. Regardless to say I can’t even transfer any files into the drive.

When I plug it in, at first it blinks in a short time interval. After about 10 seconds, a smaller portion of the LED is blinking.


  1. I’m using XP

  2. About 1 month ago (or maybe more) I messed with the DOK settings and set it to “optimize for performance” (in the device manager) so I could format it to NTFS (I think) and  transfer large files.

  3. I tried reverting the above setting to “optimize for quick removal” and then format it, but it could only be formatted to 64MB. I prefered not to mess with it.

Edit: as I suspected, the problem is with my computer. The DOK is recognized on another computer. I tried resetting of course, it didn’t help. I also tried uninstalling the driver (device manager) and then reinstalling it by plugging the DOK back in. Didn’t work.

Thanks for your help!

Something on/with your pc is the problem.  It could be low power, oxidized USB contacts, antivirus update, malware update, etc.

Sorry I can’t be more specific.  Too many variables.

Alright, I disabled the anti-virus, and tried connecting the USB to other ports - that didn’t work. Could it be perhaps a driver problem?

Anything is possible but I wouldn’t bet on the driver being it.  But if you can uninstall/reinstall it try it.