Device not recognized - firmware updater won't work

I opened my package and am trying to get up and running.

I have a 5 or 6 year old PC - Dell Pentium 1.8 ghz computer running Windows XP - SP 3 and Windows Media Player version 11.

Plugging in my Fuze v02.01.09A - I get errors recognizing device

When I have it in MSC - My computer does not recognize a device

If I try and run the Sansa Updater - I get an error message

‘’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’ The following failure occured : *************

Your device is in MTP mode ( which it is not ).  It can only be updated in MSC mode.  Please unplug your device and switch to MSC mode if you want to check for updates.

*****************************************************

If I switch to MTP device - my computer recognizes that I have foundNew Hardware and wants to use the hardware installation CD.  I put in the Rapsody CD that came with my computer and ask Windows to search for hardware installation.  An Install Wizzard window pops up searching for software flashing that I have a MTP device plugged in and I see the files moving around via picture of 2 file folders with files moving from one folder to the other.

Followed by an error message

***** that there was a problem installing this hardware. 

MTP device

Teh Device cannot Start - ( Code 10 )

Click finish to start a troubleshooter that can help you resolve the problem 

*******

Then I get a window to start all over.

So far - the only thing I’ve been able to do is get a couple FM stations with a pretty weak signal.  The sound quality is nice - but Right now I’ve got an $80.00 hockey puck that’s not even the right shape.

Additionally - the device had a 3/4 charge out of the box - and I have not been able to get the charge up at all - after being plugged in for 2 hours to a USB port in the back of computer.  I have seen the power bar drop a tad listening to 10 minutes of FM radio.

Message Edited by fireball on 01-18-2009 05:41 PM

Start with this. Unplug it from the computer. Slide the on switch up and hold it for 15-20 seconds. I always do this when I get a new sandisk device. Then plug it in make sure its in MSC mode. See if it gets recognized.

@conversionbox wrote:
Start with this. Unplug it from the computer. Slide the on switch up and hold it for 15-20 seconds. I always do this when I get a new sandisk device. Then plug it in make sure its in MSC mode. See if it gets recognized.

I followed your advice - and Got a quick box from my System that showed Fuze as new hardware - and quickly changed and my default DELL Musicmatch Jukebox media player opened up along with it.  I’m going to change my default to Windows Media Player after I get done with this post.

My computer now shows that I have a : Removable Disk (F:) to show the New Device.

I tried running the Sansa Firmware updater - and am getting the same message as I posted above.

Dont use the Firmwire updater… its a MAJOR PITA. Go to the Firmwire Updater Sticky, Follow steps in the first post to do a manual upgrade. Then you open WMP, and make sure it sees the Fuze.

All languages are now in one firmware version. After firmware update you will need to select your Language and Region preference.

 

• Ensure your battery is > 50% full.
• Extract the .zip file into a folder on your computer.
• Once extracted, drag the file to the root directory of your Sansa Fuze.
• Disconnect the Sansa Fuze and let it begin the firmware update.
• Once it finally finishes doing its update, it will turn itself off.
• Turn the Fuze on Select your language and region preference
• Once its back to the main menu, head to “Settings” > “System Settings” > “Info”, and verify the “Version” is now 02.01.17"x".

------------------------------------------------------------------------------

 

I downloaded and extracted the zip file into a folder - I don’t konw where I should be looking for the root directory of my Sanza Fuze

Edit: Do I need to install the Rapsody software to my Fuze for this all to work?  I skipped that step - b/c when I loaded the disk - expecting a Hardware driver - it appeared to me that the disk was simply a Rapsody application that would play on my Fuze media player so I didn’t install it - as I wasn’t sure I would use Rapsody or not.  I wanted to focus on getting the device up and running so I could move some files from WIndows Media Player and get a quick start up and running.

I can’t say whether or not I like the device yet - b/c I haven’t gotten it working yet - but Sandisk has about the worst " GETTING STARTED " package I’ve encountered re: a PC component or device.  I’ve set up lots of PC’s and a few Networks for friends - swapped some memory and  installed hard drives and ethernet cards - etc for PC’s - downloaded drivers online when needed - but this process is to get a simple media player up and running is about as non-user friendly as I could imagine.  If not for this site - I’d have chucked my player into a neighbor’s window by now.  Are All media players this complicated to get up and running.

Message Edited by fireball on 01-18-2009 06:45 PM

Just paste it into the internal memory folder when you open the fuze like a hard drive. No you dont need Rhapsody. I know sansa is tough but it is in a niche player. people who use it dont usually want their mind turned to mush by using a player like the ipoop where you plug it in and then it does all the work, elimintating you all together, and at the same time crippling your music in to ACC format

I tried moving the file from my Zip folder to the Device like you suggest - and I get another Error box that pops up.


Error Copying File or Folder

The system cannot find the file specified


Then I get another Error Window when I close the one I just posted


Target can not hande this type of file.


The Fuze is listed on my computer as not having a driver.  The updated firmware File I’m trying to move over to the Device folder is a BIN file.  The device still needs a driver - does it not?

did you unzip, then right click and choose copy then go and open the fuze and paste it? If not, do that. With the driver, Go into the device manager delete the driver, unplug the fuze, restart your system, when it restarts and gets stabalized then plug the fuze in.

I rebooted my machine - shut down the Fuze for another 15-20 seconds - and now it’s not recognizing the device again.  This is nuts.

The FM player sounds sweet with some modest headphones - but it really shouldn’t be this cumbersome to get an mp3 player up and running.

Do you have access to another computer? Try that, it may be your USB support. Try switching USB ports, on your pc. If its 5-6 y/o you may have a port going bad.

I swapped to an alternative USB port - and it appears to be charging whiel the other port was not charging the player.

I also have 2 new drives displaying under " My Computer "

  1. is the F Sansa Fuze

  2. is G drive which is a Removable Disk that was not there before?

I think we’re getting closer here to resolving this quarky issue.  Windows 11 now recognizes the device ( crossing my fingers it continues ) for a prolonged period of time.

Im gonna bet that it was that USB Port going bad, it happens after about 5 years sometimes, especially if they are used alot.

I think you may have nailed it.

I just synched up a few songs to my Fuze and they sound awesome.  I also just got a pop up window that my Fuze from the Sansa Updater to download the firmware update.

I was seriously about to take this thing back and give up on having an mp3 player b/c the others don’t have expandable Media drives or were out of  my price point.  I really appreciate your patience and help.  It looks like htis player wil be sweet once I get through all the initial hoops.

I’m gonna tinker with the player for a little while before I go green on Solving the problem - but it does look promising. 

My Sansa Fuze is not recognized as a hardware device through my USB port.  I have installed SP3 and Window Media Player 11.  But it still does not work.  It does work on my laptop.

Go to Settings/USB mode and take it off Auto-Detect. MSC mode should be recognized as two hard drives in My Computer. For MTP mode, open WMP 11 and then connect and see if it’s recognized. 

If it doesn’t work, connect it and go to Settings/Control Panel/System/Hardware/Device Manager and look under USB controllers. See any yellow triangles with exclamation points? Uninstall them, shut down, unplug the Sansa, reboot, connect in MSC mode. The computer will find the the USB port again and reinstall its driver when you reboot.