Cruzer Glide 16

I recently transferred nearly all of my business files, old payroll files, some family pictures off my computer and onto two Cruzer Glide 16’s.  Due to the confidential nature of my companies payroll files and business files, I unfortunately did not back up the files on line through ScanDisk.  My fault, but I thought that was best…at the time.  Things were working fine with the two flash drives, then out of nowhere… all the files were shown in the vault as some type of empty Dat file.  When you tried to open a document on the computer, from the Flash drive it was shown as a corrupted file…when you tried to open a picture that was a JPEG, it simply is displayed as an empty small Dat file image.  It is all very frustrating.  My passwords work, I can get into the vaults but everything is displayed as an empty DAT file.   But when I check the memory by going into “My Computer” it shows the 16 Flash Drive as being nearly full.  

Does anyone have any advice…  ?

Sorry, I forgot to say that I am using a Laptop PC

:smiley:    Hi Mizunoman,   (1)

Dear member of SanDisk Community, welcome.

Remember, that there are two softwares, one for Windows and one for Mac.

SanDiskSecureAccess software is supported by Windows XP, Windows Vista, Windows 7, Windows 8, and Mac OS 10.5 and up.

Use with a Mac requires other software download.

And SanDiskSecureAccess Software you must install in the UFD.

The latest version of SanDiskSecureAccessV2 , you can download (free) from here:  


1-     Download on the UFD_,_ to SanDiskSecureAccessV2_win , (if you have PC).

Beware 1: If you see thus: SanDiskSecureAccessV2_win.exe, go Tools/Folder Options, tab View, and mark: hide file extensions, and also mark the choices: hide files protected, and not show hide files protected of the system.

2-      Then, you install the program, password, etc. And you will have two files:
2.1-    SanDiskSecureAccessV2_ win , (the application).
2.2-    SanDiskSecureAccess Vault , (which is the folder that contains the encrypted files).
2.3-    If you lose or delete to SanDiskSecureAccessV2_win (2.1), there is no problem, as download other, and ready.
2.4-    But if you lose or delete a SanDiskSecureAccess Vault (2.2), missed all content.
2.5-    If, you can change the name, the application (2.1).
2.6-    Do not you can change the name, the folder/Vault (2.2), because the name is generated by the application (2.1), and if you change it, the application will not open, and will generate a new Vault.
2.7-   If, you can move on, too, to the application (2.1), a any folder.
2.8-    You can not move the folder/Vault (2.2). You the should leave, it in the root of the UFD because that is where, the application (2.1) the going “to find”.
2.9-    There is an option (in the toolbar My Vault), _ which generates a Backup _ (for SandiskSecureAccess Vault), to your PC.

2.10- To extract the file outside from My Vault, in the a folder, select and click right in the file which is inside of My Vault.

In the menu click the left button in to “save file to” and in the new menu choose new folder, and then button to save.

Beware 2: Always make, backup content, copy the Vault, clone the UFD, etc., and save everything in “safe place”.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

The files are still formated in useless DAT files.  The 16GB Flash Drive is totally full, yet every single individual file just shows up as an empty DAT file.  I just cannot figure this out. Many suggestions have been made, but nothing seems to work.  Very dissapointed that I trusted all my files to these two SanDisk Cruzer Glide flash drives.  Never again…

This is by far, the first time I’ve heard about files shown as empty. It could be caused by some virus but were you able to recover them by any chance?

:smiley:   Hi Mizunoman,

There is an option (in the toolbar My Vault), _ which generates a Backup _ (for SandiskSecureAccess Vault), to your PC.

And this backup, it works also, if is corrupted or erased the Vault, or is lost your pendrive.
Ie, it works also , with another pendrive, but with the same password.


Regards, Alfred.                                                                     (Google translated)