Cruser glide 16Gb, SDSecureAccess 2.0 --- drive not accessible

Device: Sandisk Cruser glide 16Gb

software: Sandisk Secure Access 2.0

OS: windows 7

After couple years of use, started getting 2 popups, first one prompting to reformat the thumb drive, second popup saying:  “H:\ is not accesible.  The volume for a file has been externally altered so that the opened file is no longer valid.”  I’m guessing the thumb drive is no longer usable but maybe recoverable.

I tried other USB ports in other PCs but get same prompt to reformat. I used Recuva to recover the data and it seemed to have no issues getting the data to a hard disk drive.  Seems like it got it all.  But of course the important data is on the encrypted file/folder names “SanDiskSecureAccess Vault”.  I configured  one of my extra Cruzers with the same vault password as before and copied the recovered “SanDiskSecureAccess Vault” folder to it.  Then started the Sandisk Secure Access program but it would not take my password saying it was incorrect.

Any ideas how to proceed?  I really need to get the encrypted data back, I have no backup for it.

Maybe I can re-word the question in my post.

I have a recovered vault from a faulty Cruzer 16Gb.  I have a spare Cruzer with same version of SecureAccess 2.0 on it.  What do I need to do to migrate the recovered vault to the spare Cruzer?  Just copy the vault folder and start SecureAccess?  Or are there other files/folders or hidden ones?  Right now renaming the old vault and dropping in the old vault doesn’t work.  SecureAccess bombs after entering the password.

Directly dropping a 3rd party restored vault directory onto the Cruzer with the same vault name (“SanDiskSecureAccess Vault”) hasn’t worked so far.

Seems like the Menu–>Tools–>Restore Data function has some promise of restoring from a properly exported repository.  The question is, is a third party restored directory (like I have) the same as one that was exported using SecureAccess ?  I’ve gotten a few differing results varying from blowing up to, complaining that the current vault has the same name as what I’m importing (doesn’t blow up but nothing gets imported).

So again, looking for advice on how to import a third party restoration of the vault ??  Am I going about this wrong?  Both my restored vault dir and the one that gets auto-created when I clean out the previous one contain 2 things:  (1) a system directory which seems to contain the configuration of the SecureAccess program and (2) a bunch of .dat files if any files were added to the vault, I assume 1 dat file per file in vault.  If you blow away the vault dir, SecureAccess acts like its starting up for the first time, takes you through the wizard and prompts for a new vault password.

Anyone know how to do this or advise?  Thanks in advance.

I don’t agree with 1 .dat file per file but I could be wrong.


1.  Is it possible to use the Menu–>Tools–>Restore Data  function on a vault directory restored from a 3rd party recovery app like Recuva or similar ? 

2.  And is it possible to simply drop the vault directory created from a recovery app and expect the app to work?

Recuva said some of ~450 files did not recover properly due to cyclic dependency or zero size.  DMDE did a little better.  Just wondering which of 2 methods above (if either) will work if all the files are there.  Tempted to pay for a recovery product to try for full recovery.  Something like Stellar.