recover SecureAccess encrypted files on dead Cruzer

My Sandisk Cruzer Glide flash drive started giving the “please reformat” popup and is no longer recognized except for an OS assigned drive letter that doesn’t respond.  Luckily several recovery programs were able to read and fully recover the encypted vault data and it resides on a hard disk now.  Unfortunately my attempts at reading that data by either (1) dropping it onto a different Sandisk Cruzer running the same version of SecureAccess 2.0 or (2) trying to import the data through SecureAccess’s recovery feature pointed at the recovered data, both failed.  When you think about what the binary system dir files in the vault must manage (there are 4 or 5 of them), they need to know the password, the file structure,  and some type of encryption key.  Is the key based on the serial ID of the flash drive?  If so this would be a terrible design making recovered encytped files useless without the original fully working flash drive.

Its pretty clear I need to use SecureAccess 2.0 to read and decypt this recovered vault data set.  All the files are there.  Certainly Sandisk or the company they outsourced the development of SecureAccess to, has a method for using encrypted files recovered off a dead flash drive (when you know the password).  Maybe its something where one or more of the system dir files on the new flash drive need to be used instead of using every one from the recovered drive.

Anybody know how to do this?

If the files on the original drive are important to you I recommend you find a local recovery specialist and take it to them.   Tell them the files you want to save are in an encrypted vault and you need to be able to signon to the vault.  Once you can signon immediately  export the files to a backup device.

Good luck.

PS I heard that flakey drives sometimes work if they have been stored in the freezer overnight.  I have never had a need to try this so I can’t vouch for it.

I finally got it to work by trial and error.  I had to hack and try variations of the recovered system files and the newly created vault storage files.  At one point an import created 2 vaults at which point I closed the program, deleted the file belonging to that redundant vault and restarted it.  The duplicate vault was gone and my vault tree showed up.  Then I was able to drag my files safely to the hard drive.  Although dragging directories containing directories did not work (had to move one at a time), no biggy as long as my data is safe now.

Advice: Consider this a temporary storage device.  Get your data off it as soon as possible.  It is not a reliable medium or long term storage solution, only a temporary transfer mechanism.  Also I tried 3 flash drive recovery programs.  The free ones did not get all the files but got most of them, but unfortunately not all the system files needed for decrypting.  I bought Stellar home for $40 and it got every single file, although was very very slow (8 hours to get 1.6Gb).  Confirmed each .dat file in vault corresponds 1:1 with files stored there.  For data recovery, I’d start with Recuva (free) and move to Stellar (pay) if you need it. 

Another idea I had was to swap the hardware parts around.  Remove the flash chip (since Recuva showed it to respond and had files on it), and put that chip into an identical model flash drive.  Requires soldering, you might want to buy a couple empty drives first, prove the flash chips can be swapped before trying it on your drive with precious data on it.  By swapping like this, you eliminate all problems related to the PCB board, connector, and controller.  Or you can beat on every permutation of the SecureAccess software and vault data like I did until you start to learn its tricks.

Wow  jbod!!  Congratulations!!

Thanks for sharing your update.  Hopefully it will help others that run into this problem in the future. 

Hello Jbod

I have exactly the same siutation as you last August with a Sandisk Ultra memory stick (not a cruzer) and SecureAccess V3.0 .

I have tried to play around with a brand new stick where I created a dummy vault, then replaced the Settings and Vault folders with my own, but to no avail …  I’ve tried multiple combinations of replacing some of the .dat files, without any result.

Would you mind reviewing and itemizing your sucessful procedure in a bit more detail for me, if that’s stil possible for you - that would really be  a huge help, as the Sandsik Support people only came up with perfunctory and useless recommendations .

Thanking you in advance,
with great expectations !

best regards