Corrupt files?

I just got off the phone with tech support, I’ve went through the messageboards, googled everything, and still nothing. So here it goes; About a month ago my Sannsa 2gb clip started acting funny. I noticed it was getting slow and not acting like it was supposed to. About 2 days after that I advance a track at work and all of the sudden the language is gone. The animated pictures and everything are there but there is no identifiable languange. Just gibberish, dots and squares. I bring it home and notice all of the music is gone, but the space is still taken up. I tried formatting in everyway possible. Starting with Windows media player, the program became unresponsive and crashed. (I’m using XP) Next was through my computer, right clicking the icon and formatting, it says windows could not format the drive. Then putting the device on hold, pressing the center button and plugging it in, right clicking on the drive and formatting. The bar went all the way to the end and it said the same thing, windows could not formnat the drive. Then finally disk managment. It gets to 100% and then says windows is unable to format. All of this time I am noticing that not only does my clip go extremely slow but it is also bogging down XP. It takes forever for the computer to process. The tech guy told me to use another cord, and try it on another computer, but I know thats not the problem. Of course I cannot find the other cord, that would be too easy. How do I know my cord and computer are fine you ask? I have 2 Sansa 2gb clips and the other works just fine. Even though I told this to the guy. The tech guy said there may be a corrupt file, which makes sense to me. When I pressed the center button when it was on hold the removeable drive opened, and there was only one file in there. It was a single unrecognizable file with gibberish as a file name. What else could I do. Now I have to go to a friends house and try it on his computer and call them back from his phone and waste my friend’s time before they replace it. WTF?  Any suggestions?

Search the board about running the Chkdsk utility on the player. Often this will fix it.

This is what I got, I typed in y first, I’m very unfamilair with DOS, haven’t used it in over a decade. Converting lost chains to files did nothing.

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\>chkdsk q: /f
The type of the file system is FAT.
Volume SANSA CLIP created 1/1/1980 12:00 AM
Volume Serial Number is 0123-4567
Windows is verifying files and folders…
File and folder verification is complete.
Convert lost chains to files (Y/N)? n
65536 bytes of free disk space added.
Windows has made corrections to the file system.

2,022,932,480 bytes total disk space.
      196,608 bytes in 1 hidden files.
      557,056 bytes in 17 folders.
   65,044,480 bytes in 13 files.
1,957,101,568 bytes available on disk.

       32,768 bytes in each allocation unit.
       61,735 total allocation units on disk.
       59,726 allocation units available on disk.
   A disk error occurred during writing of the file allocation table.

“A disk error occurred during writing of the file allocation table.”  Not a computer dude here, bhat concerns me.  Try running the chkdsk utilty again, and then try reformatting again? 

“A disk error occurred during writing of the file allocation table.”  Not a computer dude here, but that concerns me.  Try running the chkdsk utilty again, and then try reformatting again? 

Well after I ran the chkdsk utilty and got that message, the thing won’t even turn on now. Not when it’s connected, not even when I plug it into a power supply. So it’s deffinatly getting sent back now. The wierd thing is I didn’t even use it that much. I used it at work and a few times in the car on the stereo, but I had it for maybe a month and a half and it was shot.

And what I mean by not turning on is, there is nothing on the screen at all. It had a full charge too.

I’m sorry to hear that; it could have been a chip malfunction.  This is when you hate electronics, and love warranties …

There are two things I would do:

  1. Perform a soft reset by holding the power switch in the ON position for 20 seconds.  See how it behaves afterward.

  2. Reinstall the firmware by following the directions in the firmware thread.  Use the manual installation method.

After it reboots (if it is working at this point), on the device: Settings > Format > Yes.

Bob  :smileyvery-happy:

Well I talked to them again and the guy said he couldn’t believe they asked me to use another computer and gave me a hard time. It was a hardware problem and it’s being replaced. Thanks for the help.