Controling and Managing Sansa clip from PC

with sansa clip USB connected and viewed with windows explorer I can create folders and put new MP3 music files in them.

However, later when I want to play these pieces of music I’ve got no control on what plays. All the music files,  regardless of

folder, appear and play in alfa sequence.

Also, windows explorer cannot access the music/playlists/music options/goto list etc.

Am I missing a piece of control software needed to manage the sensa clip?

@psmith wrote:

play in alfa sequence.

 

Welcome to the tag nightmare. I only wish it was so intuitive as to play in alpha sequence, but that is a coincidence and it is playing in order of some god-awful nerdy imbedded tags. You can find a hundred posts on how wonderfully easy it is to edit them (not so on a Mac), as if it were reasonable to have to edit each of a hundred postcast files just for a one time listen in proper order.

To bad you and I didn’t get a clip+ instead of a clip which ignores folders. I keep returning to this forum in vain hoping to hear they updated firmware to recognize folders (dumb of me, partly because any update announcement is buried inside a topic). I just demote my 8gb clip to be a flac-server which is so wasteful of space that it holds just a few songs that fall in a single genre anyway and are suitable for a random play-all (so no navigation needed).
Message Edited by daft on 01-29-2010 04:03 PM

Message Edited by daft on 01-29-2010 04:06 PM

The Clip organizes and displays files via ID3 tags, metadata embedded in the files (typically, artist, album, year, genre, and title) that identifies the files.  It does not, generally (an exception for files in the podcasts and audiobooks folders, or which have those genres in the genre ID3 field), use the folder and file names.

You can edit the ID3 tags with a tag editor such as MP3Tag (which many people use), or, in Windows, by right-clicking on the file and going into Properties (there will be a a screen somewhere there, depending on Windows version, to edit the tags).  Also, if you rip a CD yourself, the CD ripper likely will have an option to fill the tags in from Internet databases. 

Wikipedia has info. on ID3 tags, and you also can search here for further info. using the search box at the upper left.

Also, I should point out that, if you play all songs from a particular album, the songs play in the EXACT order as you would find on the CD. But, if you Play All, you get all the songs in alphabetical order.

On older players, such as the Sansa e130 (which I have), it plays only in alphabetical order, whether you play all the songs on your player or all the songs from a particular album.

If you go into albums and pick play all it will play each album in alphabetical order, same for the other menus.

Tags are not hard.  Most music obtained legally will already have them.  You can tag by filename in many programs.  

Wait…there is no Year menu when you go into Music. I just checked on my Clip. I think the older players (such as my e130) have a Year menu.

I am hoping you can help.   I have a Sansa Clip 8mg mp3 player but on Win 7 I just tried connecting to pc and it is not working properly.  I can see it recognized on computer but it does not bring up the Sansa menu for storage info and controlling the files.  It also is not showing up in my Windows Media Player as connected but is.    Suggestions???  I have already updated the firmware on my mp3 player. 

@jav71 wrote:

I am hoping you can help.   I have a Sansa Clip 8mg mp3 player but on Win 7 I just tried connecting to pc and it is not working properly.  I can see it recognized on computer but it does not bring up the Sansa menu for storage info and controlling the files.  It also is not showing up in my Windows Media Player as connected but is.    Suggestions???  I have already updated the firmware on my mp3 player. 

Try changing your USB mode (Settings > System Settings > USB Mode). Updating the firmware will revert the player back to its default setting, the infamous and troublesome Auto Defect mode.

I have changed settings to auto detect and to MTS to get computer to recognise device but the menu that pops up on pc never comes up on it.  Seems computer related as my laptop works fine.  My pc though does not and that is where I need to use it with.  I am using latest version of Media Player on machine too.  For some reason I do not get that manage device menu though when I plug in player like I should.  Sigh.

Have you tried MSC mode? NEVER use Auto! MTP is only needed if using ‘protected’ or otherwise DRM-cripple files, like those from Rhapsody, Audible or other subsrciption services. If you don’t use any of these type files, you’re much better off using MSC mode where your coputer sees the device (and card, if installed) as any other flash-based external drive.

Note your computer can only see files while connected in the mode in which they were transferred in. So while connected in MSC mode, you will not be able to see or access those files that may have been added in MTP (or Auto that defaults to MTP whenver possible) and vice-versa.

I think you missed what I said in last message.  To get computer to recognize player I have to put in MTS mode.  However my point was it does not matter (in regard to getting the Sansa menu to initiate) what mode I put it in.  I do not get that Sansa menu to start up regardless.  However same player when I connect to laptop on laptop initiates that start up menu on Laptop to control files.  Such as too see battery charge, prompt to start up media player, read manual of sansa clip, etc.  This is very annoying as I cannot get my computer to work with my player.   

Seems that on laptop I only get that menu with MTP USB setting.  

Btw…both laptop and pc run Win 7 with latest media player.

Do you mean MSC mode or MTP mode? There is no such thing as MTS. MSC should always work, MTP depends on what media player and windows updates you have installed.

Sorry…was not looking at player when I replied.  Yes MSC.  Using Sansa Clip MP3 player.