Can't Find Music on Sansa Clip

Hi- I have just got a sansa clip & am using for the first time. I have charged, tuned in radio stations & downloaded music from PC to Sansa. When I disconnected the sansa from PC I could not find the music files. I hooked the Sansa up to a different PC & the music I had downloaded was there but still I can not find it on the Sansa itself. Can anyone help with this? Tks.

Are the files in a format compatible with the Clip?  Are the ID3 tags filled in (the Clip navigates and organizes files via their ID3 tags)?

I’m thinking it may be the version of Windows you’re using. I tried to find the preloaded content on my Clip on an XP computer, and it doesn’t show up. (Even after my computer recognizes the player, the folders are empty!)

Then I tried it on my sister’s laptop, which has Vista. It found the preloaded content in there.

So my question is: Is it possible to play the preloaded content on the Clip on an XP computer, and if so, how can I access it while the Clip is plugged into the computer?

When your player is connected to your computer under USB MSC mode (set under the player’s Settings/USB Mode), your computer only sees the files that had been transferred to the player when the player was connected under MSC mode.  Likewise as to MTP mode.  Regardless, all the files show up and are playable on your player, under whatever USB mode setting.  On your XP computer, you probably are connected under MSC mode; and the preloaded content likely was put on the Clip under MSC mode.

A good reason why some people prefer to set the USB Mode on their player to either MSC or MTP:  on the Auto setting, the player tries to connect under MTP mode but then will fall back to MSC mode if the MTP connection does not work; the result being, you may have a mix of MSC and MTP mode transferred files on your player, making some of them not visible on your computer without switching to the other USB mode. 

Because MSC mode is more universal (playing with a broader range of operating systems, including Linux and on Macs, and without a need for Windows Media Player on the computer), some people prefer MSC mode.  However, note that DRM (digital rights management) files need MTP mode–they will not transfer sufficiently (the DRM license will not transfer) under MSC mode. 

Well, as far as I know, XP only recognizes the Clip in MSC mode. It won’t recognize it in MTP mode (which is most likely how the preloaded content was put on the player when I first turned it on).

gameshowguy2000 wrote:
Well, as far as I know, XP only recognizes the Clip in MSC mode. It won’t recognize it in MTP mode (which is most likely how the preloaded content was put on the player when I first turned it on).

If you upgrade to WMP11, then it should recognize the Clip in MTP. And you can do that without actually having to use WMP.

So I have a mac, but my friend loaded my Sansa from his PC.  Is there anyway I can access the music on the clip from my mac.  I didn’t see a media program that was mac pc compatable.  I have VLC but when I try to open the clip with VLC it is still empty.  I tried changing the setting to MTP, but then the clip won’t show up on my computer at all.  Do you have any suggestions on me accessing this?

If your friend loaded the music with the player set to MTP mode, then you cannot access it from your Mac. Macs require MSC mode. Have him (or her) format the player (erasing all user-added content) and re-load in MSC mode. Don’t use the USB Auto setting.

Kopymac (Internet freeware) has been recommended as a good file transfer tool for Macs. 

I am disappointed with the player, very complicated and the songs do not appear. Not as good as Philips. 

If I have to go through so much, it is not worth it. 

I should send it back to ScanDisk and tell them to throw out their own trash.

Or you can send it to me and it will be up and running in a few minutes, and I can enjoy another player!  :slight_smile:

What, exactly, is your issue?

Or you can send it to me and it will be up and running in a few minutes, and I can enjoy another player!  :smiley:

What, exactly, is your issue?  If your songs are not appearing, are the ID3 tags for the songs filled in?  (This needs to be done for almost all modern players nowadays.)

I have an issue. I hooked my Sansa clip up to my mac. No music seen although I know there is a lot on there. I wanted to delete some and add new songs. Not sure why they won’t show up, how can I find them so I can delete somr or know that I have added to the player?

Also, I will need a step by step please. Most of what was already mentioned in this thread is way over my techonologically challenged head. Thanks for any help you can offer.

Macs require MSC mode on your player (Settings > System Settings > USB Mode). If the songs already on there were loaded via a PC, it’s possible (and likely) the player was set to MTP mode (or Auto Defect mode which defaulst to MTP).

This post by Miikerman earlier in this thread explains it in more detail. You should probably hook the player up to a Windows machine in MTP mode so you can access the files. Transfer them to the PC. Delete everything from the player you can see in this mode. Now disconnect, and change the USB setting to MSC. Re-connect to the PC and transfer them back to the player in this mode. Now when you connect to your mac it should be able to see all and you can add more whenver you want.

Btw, if you are going to be using a mac from now of, it’s a good idea to back up the music files there. Just don’t use iTunes. Simply drag & drop instead.

Thanks Tapeworm… I will try that tomorrow.  I did originally try the drag and drop from my music  files in Finder and that did not SEEM to work. I will try that after your suggestions, and will try Milkerman’s suggestions as well. Thanks for your patience and ideas to one who really does not have a very good grip on technology! I may be back…

The only problems I have with SanDisk is that I don’t even know how to use it with Windows XP because the files don’t show up, and because I noticed when I play a song so many times, all of a sudden, the player freezes up and I have to hold the power button for like 20 seconds for it to turn off. Happened with all of my favorite songs (because I replay them like crazy xD)

But seriously, how do I get the music files to show up on my computer? I set the USB mode to MSC, and it finally reads the MP3 player. But now I can’t even see the music files. I see the folders (because I set my folder options to show hidden files and folders) and everything, but the files don’t even show up! I really don’t get it!

Were the files put on the player when the player was set to USB MSC mode as well?  Your computer only will show the files that were put on the player under the mode that the player is currently is set to.  And so, to see files put on the player under MSC mode, the player currently needs to be set to MSC mode.  Likwise as to MTP mode.

Needless-to-say, this can be a bit of a mess, if the player has been set to various USB modes, or to Auto that may switch between them.  In that case, easiest to set the player to one mode, transfer the visible files to your computer, then repeat with the other USB mode, reformat the player, set the player to either MSC (recommended) mode or MTP, and transfer everything back to the player.  And, then, leave the player set to the single USB mode.

Hope this helps.

Zeroshac, if you have a Windows XP computer (or older) you need to update WIndows Media Player to 10 or above (I think it’s up to 11 now)… Go to support.microsoft.com and search for Windows Media Player.

Then you need to go back to settings and make it MTP again. Connect it. You should see the music if it was transferred in MTP mode. Get it outta there–copy it back onto the computer, or just delete it if you already have copies on the computer. Disconnect, switch to MSC mode, and send it back over that way.

Ok so I’m using a Mac. I’ve only used a Mac. I loaded music onto this thing but when I disconnected it from the computer they were gone. I then went and changed the setting to MCS like someone suggested in one of the replies. Tried reloading the songs onto the mps player. Disconnected. Still not there. In baby terms. What am I doing wrong?

Are the files mp3 files? If they are Mac’s own m4a files, which are the iTunes default file type,  or Apple Lossless or other Apple proprietary files, they will not show up on the Sansa because it can’t play them.

In iTunes you can highlight files, right-click and Create mp3 version. Do that and send the mp3s over to the Sansa. It plays those.