Connection problem... please help!

ok so i have had my Fuze for a couple months now and it used to be working fine. then one day randomly it stopped connecting to my PC. well, i know it knows its there because it says its charging, but it wont show up anywhere on my computer and i have done multiple searches or the hubs and ports in all three USB modes, with more then one connection cord. please help! i have done alot of searching and found that this was a somewhat common problem but every solution everyone else had didnt work for me… please help!!

Go into settings and change the USB mode to MSC.

i have. and i have changed it back and forth and on different computers. it wont find it on WMP on XP or Vista. if i turn off my laptop, and its plugged in and fully charged, and turn the computer back on, it says its connected on the device but not on the computer. i have refreshed the drivers and searched them and i cant find anything. i have also reset the player and i still cannot find it.

Does it work on a different computer?  Did you install anything prior to the error starting? 

Go into device manager and uninstall your usb ports (all of them) then reboot.  The usb will reinstall.  Try connecting it again in MSC mode.  This has solved USB errors for me before (which were my own fault for not safely removing something…)

Try setting the player’s USB mode to MSC. Disconnect all other USB peripherals on the pc. Plug the player directly into the pc(not into a hub or USB extension cable, and use a rear USB port if using a dektop. When using a notebook, plug the notebook into AC power before connecting the player. Having a USB1 peripheral plugged in may cause all other peripherals connected to that controller to only connect in USB1. USB1 might not give out enough power for the player to connect. A notebook on battery power might also revert the USB ports to USB1. Rear USB ports on a desktop often put out much more power than front ones.

i uninstalled all of the USB things and rebooted and nothing changed, it still does not recognize it in any of the USB modes.  No, it doesnt work on any other computers either. (ive tried a Vista laptop, XP laptop, and an XP desktop) still dont know what to do.

It could be the cord. The data pins are a separate connection from the charging pins. Maybe they are not making the connection.

Do you know anyone with a Fuze (or Sansa E200)? Is there a store nearby that sells Sansas where you could try a cord?

You can find generic replacement cords (look for Sansa Fuze sync or Sansa E200 sync)  on Amazon or eBay or from cell-phone accessories stores for under $5.  DON’T USE AN IPOD CABLE–it will destroy the Fuze. 

so i have another cord that i tried and it didnt work. so, my friend also has a fuze and i tried his cord on my computer and it didnt work. then we plugged in his fuze with his cord and it worked right away. i guess something must be wrong with the port on my fuze…

Holy schmoly you have WAY more patience than I do… the solution to your problem is in the first line of your post: “have…for a couple of months”, ergo, return it to the retailer if you could, or RMA it to Sandisk if not. You’ve tested it on multiple PCs, with multiple connectors… give it up and let somebody else worry about it!