Computer won't recognize e280

Hi, I know there are a few other similar posts on this same topic, but I’ll try again in case anyone has any new ideas on how to fix this problem. Basically my e280 is no longer recognized by my computer in any mode. I’ve tried many different things suggested in this forum and others, including:

  • trying different USB ports, different cables, and different computers

  • manually reinstalling the hardware driver

  • reinstalled windows media player

  • installing mtp porting kit

  • resetting user restrictions to ensure access to new hardware is allowed

My firmware version is 01.02.18, which I realize is a little old. But I can’t update it as Sansa Updater doesn’t recognize my device either. I tried to find information on how to update it manually, but I can only find the firmware and instructions for newer devices like e280r and v1, v2, etc.

I’m tempted to reformat but I’m not sure this is a good idea, as there’s a risk that if it doesn’t help I still won’t be able to add songs to it, so won’t have any music at all…

Any help would be greatly appreciated, as I’ve spent days trying to fix this thing… thanks very much!

tom

OK, well I’ve been able to update the firmware (it’s now version 01.01.24A) by putting the device into recovery mode. However I still can’t get any computer to recognize the device. But at least I know it’s not a firmware problem.

I called Sandisk and the best they could suggest was to reformat the device. I don’t want to do this though as then I’ll have no music on at all, and no guarantee that I will be able to put any back on after reformatting. I can’t send it back to Sandisk either as I’ve had it for over a year, so it sounds like the warranty won’t apply anymore.

Any other help would be really appreciated.

tom

Tom, I’m in the same situation as you describe w/ your e280, and I’ve attempted all the items you listed. Further, I’ve tried to find it listed in device manager to uninstall it. I have three different computers, none of which recognizes the player.

I’ve posted the same challenge here, but so far I have not heard from anyone with any fix. My experience w/ Sandisk support is that they went as far as they could with online suggestions, but my player was just a month beyond warranty.

Like you, I’m still waiting for someone to identify a potential solution to the computer not recognizing the player. The player says “Connected” w/ the green arrows going back and forth, but the computer does not recognized it in MSC or MTP modes.

Perhaps someone will read and send us the magic code to get them working. If you hear, I would love to hear as well.

Kurt

The v1 is a resilient wee beastie.  Hopefully, like I have, I hope you have a backup of your music.

Running with multiple models of Sansa, I routinely mess them up in hopes of duplicating issues.  Reloading used to be an arduous process, until I decided to keep backup files in Windows Media Player.  Well, if I feel like it, simply dragging from the library is also an option.

Open the reserved partition in Recovery Mode, and right click to New Folder.  Rename this folder sansa.fmt and leave the folder in the partition.

Right click and select Eject.

No matter what you do, DO NOT ATTEMPT FORMATTING THE RESERVED PARTITION USING WINDOWS.  This will alter the fabric of space and time, and a wormhole will suck your Sansa into the singularity.  Simply place the command folder there, and upon disconnect, your v1 will format itself.

After formatting (yes, this clears all data from the device), you should be able to establish normal communications.  Go figure. 

Bob  :wink:

Unfortunately, my e280 is a v.2, but I’ll attempt to apply this procedure to my model. Given that fixes for v.1 don’t seem ofter to apply to v.2, I’m not optimistic.

Thanks always; I still hold out hope that somehow something will work.

Kurt

@edprof9 wrote:

Unfortunately, my e280 is a v.2, but I’ll attempt to apply this procedure to my model. Given that fixes for v.1 don’t seem ofter to apply to v.2, I’m not optimistic.

 

Thanks always; I still hold out hope that somehow something will work.

 

Kurt

Bob’s sage wisdom and advise only pertains to the v1 models. It will not work with the v2, as it has NO Recovery Mode. For v2’s, formatting is as simple as navigating to the SETTINGS menu on the player where the FORMAT command is located.

The formatting is what I was hoping to avoid because I would lose the contents since I cannot seem to find a computer that will recognize my e280v2. I’ve scoured the threads that have attempted to deal w/ the no recognize issue. So far none of the fixes has worked. I have the sense that my player may be unfixable unless some finds another way to fix than what has been described.

Thanks for responding; the forum is invaluable.

I’ve had the same problem with an e260.  It worked fine for awhile and then it just…didn’t. 

I didn’t change anything on my computers in between the time that it was recognized and the time that it wasn’t.  I tried the following on multiple computers: different cables, ports, programs, installed latest everything, reinstalls, file deletion, formatting, holding buttons while pressing others etc., selective startups and registry edits posted various places on the web.  After scratching the top of my head with my right hand and my left arm pit with my left hand while jumping up and down on one leg, I got it to be recognized in msc mode.  It still did not work properly.  In Winamp, its drive letter would show up 3 times while in MediaMonkey it showed up 2 times etc.  In both programs, playlists wouldn’t work once the player was disconnected.  Also, organizational edits such as changing the file name would disappear once it was disconnected from the computer.  The list goes on and on.

To clarify, I re-emphasize that I tried everything that has been posted here and every other forum that google can find.  I probably have 60 hours in on this **bleep** thing.  I hate to let something beat me, but I just executed the e260 with a 20lb cast iron dumbell.  It felt good too :slight_smile:

Once upon a time, I considered sandisk to be top of the line and have purchased many of their products.  I will never again because these things are junk.  That is why they’re the most common refurbished electronic item available on the internet.  

I’m also having this problem with my e280.  If I plug it into the usb adapter it charges but it’s not recognized and the “connected” screen doesn’t even come up.  tried everything I read on here and google.   Thought it may be the cord so had my friend who has the exact same model bring his cord over but the same thing happened.   His e280 was recognized and worked properly when connected to my computer.   My next thought is if there’s a connection pin to trigger usb modethat it may be dirty and not sure which one it would be or how to clean it.   Any suggestions?  I’m glad I can still listen to it but would like to be able to add/remove songs.