Computer recognizing as an MTP device

When I plug in my mp3 (it’s an m230 512 MB), the computer recognizes it as an MTP device, but when I open it, it comes up empty. When I change it to MSC, it isn’t empty, but I can’t check my music, and in either type I can’t sync music to it. What can I do to fix this?

Message Edited by Squab693 on 06-17-2008 12:00 PM

Message Edited by Squab693 on 06-17-2008 12:00 PM


I’m having the same issue with an m250 that a friend sent to me after loading some music on it, apparently while in MTP mode (see my entry under user Griswold dated 6/14/08).  I loaded some music from my computer in MSC mode, which created a “Music” folder in the m250 file, which I could access.

I tried every suggestion I could find on this forum, and nothing worked, so I finally contacted SanDisk support.

I’m still working through it with them, but here’s the text of their first reply, with some things you can try.

Hope you have better luck that I did.

Thank you for contacting SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

We understand that you are having difficulty trying to use your player as it is not recognized in MTP (Media Transfer Protocol) mode.

Please be informed that SanDisk Sansa m200 Series MP3 Players are only supported on Windows XP (Home and Professional Edition) and Windows Media Player (WMP) versions 10 and 11. They may or may not work with other Operating Systems and versions of WMP but we do not recommend as they are not supported. They should also work with Windows Vista.

Before we do any troubleshooting procedures, please answer the following questions so that we may better understand the issue.

  • What is the Operating System running in your computer?
  • What is the brand, make and model of your computer? Is it a desktop or a laptop?
  • What port did you try, the back or the front port?
  • Have you tried it with another computer? What is the result?
  • What is the exact error code or message?
  • Is it recognized? If not, have you checked the Device Manager or Disk Management?
  • Have you tried to format or download the latest Firmware update or driver?
  • What is the version of your Windows Media Player (WMP)?
  • What have you done so far to resolve the issue?

We would need to check the presence of the device on the “Device Manager.” In order for us to do so, do the following:

  1. Right click on “My Computer.”
  2. Choose “Manage.”
  3. On the “Computer Management” screen, choose “Device Manager.”

Note: On the right portion of the Window, check whether there are error signals. These signals may appear as “!,” “?,” or as “X.” The “!” might indicate that your device is not receiving enough power. The “?” might signify that your device has been assigned the wrong drivers or has been encountering some driver conflict. And an “X” would signify that the device might be broken or you have a bad connection.

  1. Click on the plus “+” sign beside “Disk Drives” and check if your SanDisk product is showing.
  2. Click on the plus “+” sign beside “USB Controllers” and inform us if you see a “USB Mass Storage Device.”
  3. If none of those signs or errors are showing, we would suggest that you plug the device on another computer system that is running Windows XP.

If you are receiving an “!” when you open “Device Manager,” you are plugging the device on the front USB port, we strongly recommend that you plug it on the rear USB port. The ports on the rear give off a much greater supply of power than those located on the front. If the problem persists or if you are using a laptop computer, then, we suggest that you try using a USB self-powered hub. You may also want to try another computer to see if your system is the one responsible.

If you are receiving an “?” when you open “Device Manager,” this might also be true if you are receiving the error message "USB not recognize for your device. In order for you to do so, we would suggest the following:

  1. Right click on “My Computer” and choose “Manage.”
  2. On the “Computer Management” screen, go to “Device Manager” and click the plus (+) sign beside “Disk Drives.”
  3. Right click on the SanDisk entry and choose “Uninstall.”
  4. If this fails, click the plus (+) sign beside “USB Controllers.”
  5. Right click on the “USB Mass Storage Device” entry and choose “Uninstall.”
  6. After doing this, unplug and plug the device back to re-assign the drivers and re-install it on the system.

Let us try to manually install the player and let us see if this will help.

Let’s open “Control Panel” then choose “Add Hardware”. Tell the wizard that you have already connected the hardware. In the list, choose “Add a new hardware device” at the bottom. Choose “Install the hardware that I manually select from a list.” Choose “Portable Devices”, then MTP (Media Transfer Protocol) device.

Should the above steps fix or not fix the issue, please do not hesitate to let us know by sending an Email. We would be glad to be of assistance to you.

I have just bought an m250 from Amazon and am very disappointed with it – I am running XP Professional on a Sony laptop and when I plug the m250 in I get a message saying “Found new hardware” but that’s it – no wizard or anything. The little CD that comes with the player isbn’t recognised by my laptop, so I can’t install whatever is on it. So I am stuffed. (I have tried plugging the m250 in to an XP Pro desktop as well and I just get a ‘bong’ from the speakers and nothing else).

I have previously bought ‘no-name’ MP3 players and they have all showed up immediately as additional hard drives, automatically, no spftware drivers to install or anything. Sandisk have really fallen down on this one, if my experience is anything to go by. I will be giving them a very bad rating on Amazon.

Having said that, I will try the actions suggested by Griswold and see what happens.


Also, if anyone from Sandisk is reading this, why don’t you post the contents of the driver disk on the Downloads section of the website? Then people who have problems with the CD (or don’t have a CD drive on their PC, as some don’t) could actually get hold of the software. You guys are providing what I believe is called a “poor user experience”.

Oh and FWIW, the m250 *did* show up straight away on my wife’s Eee PC – which is powered by Linux. Notch up another one against Microsoft.

Message Edited by xmfclick on 06-25-2008 10:05 AM