Clip's headphone jack

I just got my Clip today; I’m loving it! Wondering about one thing, though: has anyone noticed that the headphone port doesn’t seem to be deep enough for the headphone plug? Is this normal? Am I just not giving enough force? (I didn’t want to break the Clip.) I tried a few different pairs of headphones and it was the same.


Message Edited by Andrew-PhB on 12-20-2007 03:37 PM

From my experience with the standard ear buds that came with the Clip – I had to exert a little extra push to get it to go in all the way.  It does go in all the way until the plug “bottoms out” againtst the case of the Clip.  I can’t tell you anything about after market items because I just use the factory ones.

Thanks! It took more force than I expected, but I got 'em in! Sounds a lot better now!

Ok, I just got a Clip that seems to have everything working; that is besides what I thought was a design flaw with the headphone jack.  I really like the player and am willing to live with the plug sticking out a bit instead of going all the way in like it should.

However, I saw this thread and am wondering.  But I have to double check before I try forcing the plug in further (I really dont want to break this one since it has taken four tries to get one with everything working).  With all four Clips that I have had, the headphone plug does not go all the way into the jack.  With the first one I tried forcing it a bit since I could feel that the soft backing inside the jack had some give.  However, the sound cut out completely when it went in too far (or at least I thought it was too far; it still wasnt all the way in).  I get sound in both left and right ear buds, so I thought the plug was designed to stick out a bit.

Should I really force the plug in so it sits flush with the case (as you would normally expect it to)?


The supplied earphone plug doesn’t stick out at all, but a connector cable to my car’s Aux Input sticks out about 1/8" or so as well. Pushing it in with a little force, and then letting it go, results in it just springing back to the same point. It’s just the same with my Creative Zen Stone Plus.

It works perfectly in both cases, so I’m just going to let it be.