Clip Zip Stuck on a Green Screen

Hello,

I have been trying to fix my clip zip, but no luck. Perhaps someone may have experienced the same issue.

I received a Kingston 4gb miscro SD card as a gift, and tested it on the player.

I was able to view the music on the card and play it with the player.

I believe it was the next time I used my player it showed a message to reformat (connect to a pc - formating was broken - FAT32 I believe). Since then, it has been stuck on a green screen whenever I power on. I have taken the card out and still the same. When I plug into USB, the computers I have tried on do not pick the sansa up. I have tried the firmware updater, and it is still asking to plug the device in (not recognizing it).

Thanks if you can help.

Kevin

Have you tried a reset? (Hold the on button down for 30 seconds or more–sometimes even a minute.)

Thank you for responding.

After the reset, the player will restart still stuck and showing a green screen.

The stu (http://www.edmontonescort.com) ]Edmonton Escort you (http://www.edmontonescort.com) ]Edmonton Escorts from seven  to three days of thercircumstances at the time, and how they (http://www.edmontonescort.com) ]Edmonton Asian Escort memories formed would be lasting ones, the group (http://www.edmontonescort.com) ]Edmonton Asian Escorts participants again

does it connect to the computer? if so try formatting it and reloading the firmware. links for the manual firmware are at the top of this board. 

I have tried a few computers and they will not detect it; I have also tried loading the new firmware and it will not pick the clip zip up - it stays on the step of waiting for the zip clip to be connected (It is conected but will not pick it up).

It does turn on when plugged in (the green screen shows) but will not detect.

Thanks you again for responding.

I think it’s time to call SanDisk Tech Support. You may need a replacement unit under the warranty.

al you have to do is get the new firmware at the scandisk site.

get your firmware at their web site scandisk.

Just get your firmware at the scandisk site.

Is there an echo in here? :confounded:

And on a year-and-a-half old thread? :neutral_face:

I thought I’d note, don’t give up on this if you have this problem. I figured my player was dead, since it had gone green screen all the time, and the computer couldn’t see it when it was plugged in. I was going to call customer service to see if anything more could be done, but then noticed, out of the blue, the player, which had been connected to the computer all night with a green screen, had turned off the screen. I turned it on, and it showed the USB plug graphic indicating it was plugged in, with the battery charging animation. However, there were no words on the screen. I used other buttons to navigate, and it navigated among screens and menus, but with no words anywhere.

If you get to this state, your Sandisk Sansa window should be up on the computer, too. If so, don’t unplug the player! Go get the firmware MANUAL updater from Sandisk, download, extract, and move it to the root directory of the player. Then when it’s done transferring, unplug, wait for it to turn off, and turn it back on again according to the manual update instructions. This worked for me. The player seems to be working again.

…that’s the important stuff. But I should mention there were two further steps in this saga before I got there. The plugged in screen showed up, I looked around on the player, then tried to use the Firmware Update link on the Sandisk Sansa window that comes up automatically when the player is plugged in. This did not work - it gave me a file not found error. I downloaded and ran the Firmware Updater Installer, but running it did absolutely nothing. Finally, I decided to try a normal reset. I unplugged the player, and pressed the power switch to turn it off. It went green screen again. And stayed. I decided to give it another chance with similar circumstances to revive as it had before, and a few hours later, again without warning, it did. At that point I was ready with the manual update .bin file and the instructions on the website. And it seems to have worked. So… DON’T unplug the player if you’ve got it to be noticed by the computer again after a green screen failure!

My process:

  1. make sure player is charged

  2. connect to PC and format the player’s internal memory

  3. perform a manual update

  4. unplug and give nature a chance to take its course

My update was the result of installing Rockbox, but I don’ think it’s necessary if you don’t want to.

I still have this problem and I dont know what to do. I cant reinstall the firmware because the player doenst get recognized by my pc. reset didnt do anything, neither did msc mode. nothing but a green screen all the time.

You tried holding down the center button while connecting the player to the pc?

Yes. That’s what MSC mode is, isn’t it?

ANother thing I’ve tried now is leaving it on and letting the battery drain. but when i power it back on it’s still the same green screen.

If you plug it into a cell phone charger and turn it on, I guess you also get the green screen?Did you try giving it a long charge with a cell phone charger? If you can’t boot it completely to format the player, and can’t get it to connect, then there isn’t much else you could try.

If there was a card in the player, did you remove it, then try to turn it on, or to connect?

Tried charging with the mobile charger, didnt work. No card in the player.

I guess it’s time to give up. It’s a shame, I really liked this player…I think I’m like a month or two out of warranty, too. sigh.

You tried holding down the power button for over 30 seconds then tried to restart it? 

One last thing i thought of is to leave it on until the battery is exhausted, and it turns off on its own. Then you could try again to connect it to the pc while holding down the center button. If it connects, then format the player using your pc. give it a long charge, then disconnect it, and format the player again using the players menu. If it didn’t connect, then give it a long charge with a cell phone charger, then try to connnect it to the pc while holding the center button. If it still doesn’t connect, then hold down the power button for at least 30 seconds, then try to start it up. If it starts up, then format the player using the player’s menu. 

I can’t think of anything else to try, and if all those things don’t work, your player probably has a hardware problem.