Clip + will not reset

My clip+ stopped working. It is 60% charged but will not switch on, nor will a reset work and computer does not recognize it

You might try plugging it into a wall power source and leaving it alone for a day or 2-that sometimes has worked.

Thanks Milkerman, I am trying that 15 hours so far: no luck so far: will keep trying.

Also try different cables! – You never know, you know!

I have tried different cables, no luck. I have also tried loading new firmware but this is impossible as there is no directory, 'cos the computer can’t see player. I guess I will have to buy a new MP3, but I don’t think it will be a Sansa

Sorry for you – as it seems hopeless indeed. But I wouldn’t count out SanDisk players because of your bad experience, I think you can have similar bad luck with other brands. Also, you wouldn’t get the same sound quality for the same money, if that’s what you’re after.

OK jaZZ I was feeling grumpy. I will buy another clip+ as it is very good usually.

Sansas are useful, just don’t mess around too much with firmare or password.