clip screen rendered unreadable (after plugging into mac, but also with pc)

hey all,

i have recently switched to a mac, so i formatted it, switched to msc mode, and upgraded to the newest firmware (actually using another pc). so, using the mac, i put songs on through drag and drop and then unplugged the clip and listened to it to test if the songs transferred successfully. i got an error message on the computer reminding me to eject it first to prevent data loss. the clip worked fine. i plug it back in and continue to transfer stuff (potentially formatting it again, i can’t remember). then i unplug it again, without ejecting it. the screen is not frozen, it still boots up, plays music etc. however, it seems that the portions of the screen no longer display the color. i can only see bits and pieces of the sandisk boot up screen for example. I also can’t see the battery. i can still read some stuff enough (allowing me to try resetting the settings, formatting it, as well as re-installing the firmware–which i couldnt do because it seems that formatting the clip does not erase firmware). you forum guys seem very helpful, as i was reading some of the other entries to figure out using the clip with a mac etc. thanks in advance!

upon closer look, it seems that the blacked out portion is a mixture of the “sandisk” start up screen and the lock “hold” image. they are just off to the left it seems. craziness.

Have you tried going back to the previous firmware? Or reaplying the firmware update?

how would i do that, i tried formatting but the firmware was still up to date?

DO NOT format the device from a Mac!

If you are running with a Mac, it’s best to use the Format command on the Clip itself. 

You can reinstall a new (repair) copy by dragging aand dropping a new copy of the m300a.bin (example) into the root directory of the Clip, as described in the Firmware thread.

Bob  :smileyvery-happy: