frozen screen, clip cannot be seen in PC or Mac

after much frustration, I found that I could connect with my apple MacBook Pro by holding down the center key on the clip (the clip was on hold) and then connecting the USB cable to the computer and clip device. The apple could see the entire file. … next, as one of the forum folks indicated, I could use the disk utility on macintosh to erase the device but selecting the dos option as the default option. Then I ejected the clip by dragging the icon to the trash. After this I turned the clip to on and everything worked perfectly! … thanks to the forum folks…!! It would be good if there were a better search enjine on the problems.


what suggestions might you have that are better then keywords?

That worked! I had to have the clip off, on hold and holding the center button while plugging it into my Mac. I erased using disk utility. Now the clip is completely (except formatting info) clear. I drug one song over and tested it and it worked.

I’m wondering of the clip thinks it’s still connected even after you eject it from the Mac and when you unplug it the memory gets corrupted. The display still say “connected” even after you eject it.

Now maybe I’ll update the firmware from the PC.

I have now moved from a frozen screen to one that says connected—but it does not show on my OSX desktop…ideas?

See if disk utility (or what ever the PC disk utility is) sees it.

I have the same problem but the “hold the middle button thing” is not working. I have tried just about everything!!

Very angry!!

Also, it is not seen from the disk utility.


Holding down center button (hold switch on) and connecting to Mac will work only limited times, after that its a ‘brick’. So if you can exchange it for a new one, you might try this:

  1. Connect to computer to charge, it should show up on Desktop( Clip display should show ‘connected’ and battery charging status). While this is going on, download update firmware 01.01.18A, this will open as ‘m300a.bin’ on Desktop. Do not try to open .bin file, leave it alone.

  2. Once Clip is charged (few hours), DO NOT try to eject or dismount. Drag the 300a.bin file and drop it on the Clip icon on your desktop.

  3. DO NOT dismount by command or dragging to the ‘Trash’, but just disconnect the Clip from the USB cable; I know this is not what you have been taught, but this is an exception.

  4. Now turn the Clip on, the display should indicate updating process. Once completed go to the menu and select ‘Settings’, check that ‘System Info’ shows 01.01.18A. Once verified, scroll down the System Info menu to ‘USB’ setting and set it to ‘MSC’. With luck the Clip should now work as an MSC device on the MAC. Future connect and dismount procedure of ext. device, including ‘Clip’ from the Mac can be resumed.

DISCLAIMER: The above worked for me, but if you try it, you do it at your own risk.

I am SO pissed. I have been at this for 9 hours and my kid still has no player.

I FINALLY got this blasted device back on my MAC computer with the center button process–I loaded 300abin–and now for last hour+ it will not get off firmwareupgrade in progress.


I have NEVER been so upset with a product in my life! And easily the worst support on the planet—at least the worst directions. Who knew this would take all day and still have NO RESULTS!

Any further advice would be appreciated.