Clip+ not turning on when disconnected from USB

Yesterday evening my Clip+ was connected via USB for several hours (for charging and adding music).

This morning when I wanted to use it, I was no longer able to turn it on. I tried several times resetting it (holding power button even for up to a minute) with no success.

But when I connect it via USB again, it is still usable as mass storage and shows the “Connected” screen. So it seems to be not completely dead.

After disconnecting from USB it immediately turns off and can’t be turned on. Like there would be no battery in it…

I’m sure that the battery is not dead, as it worked fine until yesterday and should also be fully charged. I also tried reflashing the firmware, but because it immediately turns off after disconnecting from USB this was also not successful.

Any other ideas I could try to revive it? Or is this a warranty case?

It really sounds like it’s a battery issue.  Early on, the Clips had a sensitive battery connection wire that could become detached (such as with a fall, etc.).  I haven’t heard of this with the Clip+, but your Clip+'s powering off as soon as detached from your computer seems to be indicative.  You might try connecting via the USB to an AC power source and see if the behavior is the same.

Now the positive news is, it sounds like you are still within warranty . . . .  SanDisk in the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:

While it is off, remove the card in the player if there is one.I assume that you have a copy of everything on the player on your pc. Since the player does connect to the PC, connect it, and format the player using your pc. format it as FAT32. This will delete all the songs on the player. disconnect it, then you will probably be able to turn on the player. If not, then you have a battery(or battery connection) problem. After turning it on, format it again using the player’s menu. After that, reconnect it and reload the songs.

Just formatted the player (with removed card) with the PC, but it still doesn’t turn on.

So it really seems like the battery (connection) is the problem.

Thanks for your help.

Same here. The only way to turn this thing on is

  1. Reset: push power button for > 20sec

  2. plug into USB

  3. after it connects to PC you can unplug and unit will keep working

but if I turn power off …

I have to repeat sequence above.

ildar, I assume that you have copies of the files on the player also on your pc. Format the player using the player’s menu. This will delete all files on the player. Download the latest firmware and install it on the player(even if you already have the latest firmware on it already). Formatting and reloading the firmware solves many problems.