Sansa Sandisk Clip+ does not turn on! :(

My Sansa SanDisk does only turn on when i connect it to usb. It shows that the battery is fully charged then though. I tried to reset it (holding on/off button pressed for 30 seconds) and I tried to start it in MSC mode and I downloaded the latest firmware put it on the root folder and tried to start it/ and connected it. Nothing helped. I bought the mp3 player 2 years ago. It happened like this before. then it worked again when I left it till the battery was completely empty, charged it again and it worked again. but then during playing some songs it turned itself off (while it was running with rockbox) even though the battery was still charged and now it does not turn on anymore. Tried to uninstall rockbox, it still does not turn on when not connected to the computer. Also not when I turn it on in original firmware mode. What can i do??? is there any other option for a reset? maybe connecting it to the computer without having it into “connected” mode but just using the computer as power source and then resetting it or something??? otherwise how can i discharge it maybe to reset/recharge it again? video: