Clip keeps freezing

Hi; I bought my clip five days ago and it seems to be defective or it is something with it’s firmware(2.01.32). I got the 8g v2 clip.
The problem is that the clip seems to freeze when I listen to music and I push the home button or every time I try to create a go list (after I check 4 to 5 songs ) it freeze.
I reformatted in fat32 (although I 'm not sure if it is the right format for the clip) but the freezing problem still exists.
Should I take it back to the store or is it something it can be adressed somehow?

I posted a response to your inquiry placed at the anythingbutipod.com Clip forum:

Did you try a Clip reset (on switch held up for 15-20 seconds); and/or a reformat from the Clip itself (Settings/format)? Those might help. You also could try reapplying the firmware, in case a software glitch has appeared over time (see the firmware upgrade thread at the top of the forum).

Also, and perhaps obvious: what is the format and bitrate of the files that skip? In other words, does the Clip support them?

Message Edited by Miikerman on 06-30-2009 09:48 PM

Thank you for both replies Mike. I haven’t try to format the clip from the format option it has on it’s menu, I only did it through windows but I ll do it now. As for the reset I’m not sure it’s working. I tried it a lot of times but nothing seems to happen other than turning on or off the clip. I don’t know if I should read any message on the screen by doing this but I found a similar option in the settings menu ( reset all ) and I tried this.

Also last night I decided to reapply the firmware by coping the “m30pa” bin into the directory of the clip. Then when removed the clip from my pc, I got the message that was upgrading the firmware. Now the weird thing is that message was on the screen for 3 hours until I decided to turn it off. Turning it on back it seemed that everything was reset because it was showing me the options for the language.I don’t know how much it actually takes to reapply the firmware but I know that this shouldn’t be so long. After that I tried using again the clip but I had the same problems as I describe in my first post.

In the clip I have placed only mp3 and I tried a lot of them just in case that some of those were corrupted (I hope that jpg, that are in the folder as the cd cover, don’t create any problem). Actually it doesn’t skip them but every time I try to create a go list, after choosing some mp3 (usually 4-5)the clip freezes and I have to turn it off. Sometimes it also freezes on the logo screen. Those are not the only situations I got this freezing problem, it could be anytime, even when I push the “home” button or randomly in the menu.

Well, after formatting the disk and resetting it, the situation got worst. Every time I try to copy an mp3 folder into the music directory of the clip, it seems to freeze and the hole procedure its stacked. I even have to remove the clip from the system in order to terminate the application. I 've even tried it in different pc just in case there was something else that was causing this.

I think I’ve tried everything I could and the situation only got worst. I believe it’ s something with the hardware that cause the problems. 

If it was me, I’d try refornatting from the Clip’s Settings one last time (maybe it’s just me, but sometimes a software command that I use doesn’t really click the first time); and then contact SanDisk telephone support for help.