Clip + dead and not recognized after a FAT formatting

Hi folk,

So here’s the gist of it:

I bought this new awesome mp3 player into which I thought to add some flac tracks for audiovisual pleasure. However the file transfer made the operating system (Windows 7) freeze and in the end I had to resort to just plugging the USB out. However this is where the problems really began, as the device notified me of a corrupted FAT file system. At first I tried to access the file system through the windows but it didn’t let me access the disk without the explorer freezing. So I went off and tried to format the thing with Ubuntu. The system gave out an error whenever I tried to format the 7.9GB partition into FAT. After I plugged the Clip + out of the computer it refused to start at all or be recognized by the operating systems.

So the question is, did I manage to completely brick the poor device? Is there a method to resurrect my new friend? I tried to search for similar topics/problems other people have had but with no avail.

Thanks beforehand for the possible replies :slight_smile:

@mrfriday wrote:


So the question is, did I manage to completely brick the poor device?


Seems so.


Is there a method to resurrect my new friend?


Not if you can’t get it connected to a computer. If you somehow manage it though, format it to FAT32, not FAT. That’s only for disk sizes of < 2GB.

1 Like

Of course, if the player is new, sounds to me like you could exchange it with the seller or contact SanDisk for a warranty replacement.

In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:

1 Like

Thanks for the fast replies. Contacting SanDisk directly sounds like the next best thing to do.

However, I’m still interested if it’s possible to force the USB connection to the bricked device and directly copying the firmware image to the device (as I think the problems I’m experiencing have to do with overwritten firmware). I did something similiar to a previous phone of mine with dd (the unix command line tool) but this time there doesn’t seem to be any way to access the clip +'s flash memory without tinkering with the hardware, is there?

Kudos to you guys :slight_smile: