Clip 4gb won't turn on, connect, charge

I’ve tried searching for a solution, but haven’t had much success. I’m going to guess I’m SOL on this issue, but here it goes:

I’ve had my clip for a little more than a year, and haven’t had any problems with it. Last week when the battery was running low I tried to charge it. When plugged into the computer or power outlet or car charger, it doesn’t recognize that it has been plugged in (screen doesn’t turn on when off, and when on nothing changed). I just let it go, and ran it until the battery died. Now it doesn’t turn on for more than anything than to tell me the battery is low, and it still doesn’t charge/connect to a computer. I’ve used 3 or 4 USB cables, a few different computers, but only one car charger.

Have you tried charging it via AC?  It might be worth giving that a try.

Try holding the power switch up for a minute while it is connected to a power source. If that still doesnt work it could be a battery issue already.

This might help too

Changing battery

I tried all the usual tricks of holding down the center button, holding the power switch up and connecting and disconnecting at different times with no luck. My ac adapter has been stolen by my roommate so I can’t try that out.

I’m not sure if it would be a battery problem because after I started having this problem I was able to use it until the battery drained down.

You can pick up an AC charger at an electronics store or even Target, Wal-Mart, etc.  If you can wait for the shipping, a place like has them for as low as a couple of bucks.