Clip not recognized by computer,not charging

My computer does not recognize my clip (had it for 5 months, latest software updates, been working fine, but it is my second Clip first one died too) and it is no longer charging so I can’t change it to a different mode becuase “battery low” comes on as soon as I disconnect from computer- it’s showing ‘connected’ while plugged into computer, but not showing the battery charging.  I have tried the turn off and hold center button technique to no avail.  I have tried reset - doesn’t work.  I cannot find the device in the device manager.  Other suggestions?

Try connecting it to a DC source to charge it.  Many cell phones/chargers have a miniUSB plug,  you can use that for charging the device without connecting to computer.

I have tried plugging it into another charger: 

Input: -100-240VAC, 0.4A  50-60Hz

Output: 5.4VDC 2.0A

That doesn’t work either.  It says it’s ‘connected’, but the battery does not charge.

So, my computer cannot charge it, a DC unit cannot charge it, nor does the computer recognize the unit.  

Oh, and I do have WMP 11. 

This thing is pretty clunky in terms of the interface. . . . .  So what do I do now, pitch it?