Clip+ 4Gb won't connect to anthing


I made the mistake of putting my Clip+ in MTC mode rather an MSC or Auto and then connecting to my MacBook (I was trying to figure out how to get at the “hidden” music on the device from the Mac side – a very odd thing in itself).  For this sin I can no longer connect to any computer.  

Now I get the dreaded “Not enought space…” message and it won’t mount on either a MacBook or Windows 7 machine.  I’ve tried everything the internet has suggested, including:

  • holding the center select button down while plugging into the computer

  • letting the battery run down

  • hitting the center button multiple times during boot up which lands me in the ‘refreshing media’ screen, but then it hangs until the battery runs down

It simply won’t mount anywhere so I can’t even reformat the memory. Is there some secret button sequence I need or is this thing now toast just because a setting off?  Seems inconceivable.

Additional info:

  • no micro SD card

  • latest firmware update installed (worked fine afterwards, so I don’t think it’s that)

Try <<.

Open Win7 and Windows Explorer. Connect USB to computer. Hold <<. Connect.

Well, I see in the other thread you joined that you tried that already.

I’d suggest you call Sandisk, 1-866-SANDISK. And if they do fix it, please post their solution here.

Yours and the other post from October are the first time I’ve seen this problem reported, and I wonder if something has changed in the Mac operating system, which in the past has generally just ignored MTP. But that doesn’t excuse the mess.

Also, if you realy feel like tweaking you could again attempt to connect to Win7, go into Control Panel/Device Manager and see if you get one of those yellow-triangle exclamation point things where it’s failing to connect. Right-click on it, uninstall it, try again. Don’t know if it will do any good.

The point of MTP was:

  1. to provide a mechanism for subscription services, like Rhapsody and library audiobooks, to send digital-rights codes.

  2. to make Windows Media Player/Sansa work like iTunes/iPod for playlists, synching, etc. Apple has an advantage because it controls both hardware and software on a limited range of products–the walled garden. Windows is installed in a far more variable bunch of gizmos and inevitably has more glitches as a result.

I’ve always set my Sansas to MSC at the first opportunity.

The big culprit–not just in our dinky little music players but in situations where it really makes a difference, like medical records and medical imaging–is proprietary software that’s deliberately incompatible with competing systems. But that’s not going away.

@jimschlemmer wrote:

It simply won’t mount anywhere so I can’t even reformat the memory.

Yes, you can! By using the Clip’s internal formatting tool: Settings –> System Settings –> Format. From what I’ve read (here) this is a promissing way of curing a Mac-corrupted Clip+.

Hi Jim, it would be really nice if you can update this thread and see if that step given above has worked for you.

Except that he already wrote that he can’t get past the Refreshing Media screen, which means he can’t get into the Settings menu. Duh.