Clip+, 32 GB microSD, class 10, no files found

The general consensus in this forum seems to be that 32 GB microSD cards can be used without problem with the Sanca Clip+.

So I got an 32 GB, class 10, microSD card from Samsung.

After I installed it, the player created the following directory structure:

/

|

± MUSIC

   |

   ± AUDIOBOOKS

   |

   ± PODCASTS

Which looks odd.

I then copied (via USB) MP3 files in every folder. However - after a rescan - they are not found.

When I try to display them via the View Folder option, the external drive is shown as empty.

I’m using firmware V01.02.15P

I also tried to mimik the folder structure used in the internal drive, but with the same result.

Any hints why that is and how it can be fixed?

Thanks

P.S.: My old 8 GB, class 4, Scandisk microSD works fine.

Maybe it’s a counterfeit card? There’s a lot of them out there. It could also be defective. You can test it with h2testw.

Thanks for the tip.

However, h2testw couldn’t find anything wrong - which did not surprise me, because the card was from an well know dealer, in the original packing.

What so odd is, that the player did create those directories, so it must recognize the drive.

And the files on the microSD are accessible via USB while inside the player.

Only the scan does not find them.

I presume that the part of the software which scans the directory structure expects them in a dedicated subdirectory (podcasts in PODCASTS etc.).

Does the fact that the drive created this strange folder structure ring any bell?

I would have expected all folders on the same level, not two inside the MUSIC directory.

So the software might “simply” look in the wrong place for the files and does not find any, but I have no idea what the reason might be.

Any other ideas?

I had the exact same situation. I installed a 32gb micro. I formatted it through Windows. This allowed it to be seen on my computer and even on the Clip+. I transferred my files to it. When I tried to access them the file showed empty. I then updated the firmware. No change. I then came to this forum. In reading the threads I found that you need to format the micro with a special formatter. I downloaded this formatter an re-formatted my 32 gb micro. It now works like a champ. I can copy my files and they show up just fine.

No special formatter should be needed.  Having said that, the SD Association’s formatting tool sometimes can clear away problems and is a good source to try. 

https://www.sdcard.org/downloads/formatter_3/