Can't transfer the files from IOS to stick

Hi My first experience with Sandisk wifi stick

I updated the firmware to the latest one , the update has been done corectly

On the Android (motorola phone), I can read and write via stick wi-fi. no issue

On IOS (Iphone 5s, Ipad pro, IOS 9.3.4 ), I can read the files, I can stream video and music, but I can’t write from IOS. The led blink slow, not fast , and transfer do not start. 

If using the useb port (macos or windows), the transfer of files is ok (read and write)

What happen with IOS ? Why can’t write the files (can’t transfer from IOS to stick via wi-fi), just read? 

can you be a little more specific as to what you mean by you cannot write files?

iOS sandboxes third party apps so you can only access pictures and videos stored in the iOS native camera roll (native photos app)

From the media drive main screen select videos or photos. Then at the bottom of the page you will see and option to view from the drive or the iOS device. Select the iOS device then you will see the pictures or videos stored in the camera roll of the iOS device. select the items you want to transfer and then select the share button at the bottom and choose save to media drive. All files will be saved in to the media drive upload folder. 

write, mean I can’t trasfer files from IOS to stick 

I din’t understand what do you mean sandboxs? I using IOS application from sandisk. I tried to follow your instructins but I have no any share button, I have a + buton , after this I can access camera roll, I choice the pictures what I need and choice the location where I need to transfer. Nothing happen , the files do not transfer to the stick.

If I will look at the sandisk IOS instructions, this is the process to transfer the files form IOS to stick

What product do you have? You posted in the sandisk media drive board. It does not seem you have the media drive. If you let us know exactly what product you have we the moderators can move the post to the correct board and we can better assist you. 

Sandisk Connect Wireless USB Memory Stick 120 GB

Can I have a resolution?

Sorry but this stick is unusable on IOS, Camera Roll backup do not work, share file from Camera rol do not work, Upload files from IOS do not work…this is a ■■■■.

Sandisk support is a **bleep** 

I will return the stick and I will take my money back, I swear, this is the last SanDisk product that I bought

Mods moved your post to the correct board.

Please keep in mind this is a users forum. If you are looking for a response from sandisk support then open a ticket with them. Here is the link to their knowledge base. You can open a ticket there.

I have the wireless stick as well and can confirm it does in fact work in iOS. I have an iPad mini, iPhone 6 and iPhone 5s all running iOS 9.3.4 and the wireless stick is working for normally for me. There seems to be something unique about your iOS device/s

Have you allowed the app access to your photos? You can check this in the iOS settings > privacy > Photos > connect drive. Make sure you have this access turned on for the connect drive app.

If that is done and it is still not working you may need to send a log to sandisk support. in the connect drive app go to settings > about and at the bottom select start capturing logs. Once that is started try to transfer some pictures. Once the issue has occurred again go back to settings > about and select send logs. This will open your default email account with logs attached to the email. Email that to the sandisk developer email and yourself then submit a ticket to sandisk support and attach the logs. 

Hopefully that will help debug what may be causing the issue in your environment. 


i just bought sandisk connect stick 64GB. i already install the program in my iphone but i can not transfer file from iphone 6 to sandisk.and it said ; connection interuptted so the transfer is failed…

can you please help me, what should i do.


I am on IOS 10 on an iPad Air. Unable to transfer photos from my iPad to the Wireless stick. Even transferring one image file takes forever. Manual. Connect drive has permission to access photos on IPAD. Overnight attempt to back up photos…about 30 pictures got transferred.

Transferred some photos from my Macbook Air running Yosemite in the USB mode.  Later I connected to the the wireless stick from the iPAD and can view thumbnail images. When I click on one and try to view that image I get a message saying SD card corrupted.

Confused. Would appreciate help. Thanks

I have used the Sandisk Connect app on Android OS to copy various files I want to save from the phone to the drive, including podcasts that I had downloaded and wanted to back up.  Unfortunately, my Android phone recently broke and I needed to fire up my wife’s old iPhone 4s (fortunately she saved it for just such an emergency). 

So if I get this straight, Apple has restricted access so that I cannot upload anything but native photos and videos from the phone to the drive?  Not being able to upload podcast files is a huge disadvantage here.  Pretty useless having the drive if I’m not free to copy and paste the files I choose.  Just another example of why I tend to prefer Android devices and steer clear of Apple’s proprietary policies.

some applications have the share extension enabled. if the app you are using has the share extension enabled you may be able to share the file with the connect drive app and save the file to the drive. I do not think the native podcast iOS app has this feature enabled however if you can find other apps to get the podcast you may be able to use share to get it to the wireless drive. 

Hello everyone, I have found a fix. I was having the same issues as you all. App kept crashing or only one or two files backed up then all of a sudden it stops saying ‘Backup complete”. The fix is instead of connecting to the SanDisk built in wireless network connect to your home wireless network. Once your phone is connected to your wireless network you then need to connect the SanDisk Connect to the same network (Go to the Sandisk menu and at the top where it says internet connection this is where you connect the Sandisk to the same network. I’m using an iPhone 7 and even now as I’m typing this message the SanDisk Connect is backing up with no issues. Once your files are backed up you can then reconnect to the Sandisk built in wireless network and all your files are now there. Now you can turn on Auto Backup. Goodluck and I hope your issues have been resolved. Remember connect the Sandisk to a good wireless connection not the built in Sandisk wireless connection.