Can't reset my Sandisk Sansa E250

I am having major trouble trying to completely reset my MP3 player. I tried holding the power button down for 15 seconds and it was a no go. I tried to reformat to a NTFS file system and now when i try to boot my MP3 player rockbox says No partition found. There is also no reset button on my MP3 player. I even took it apart to find a reset button. No go. So if anyone can help me out I’ll be really happy. It is really ******* me off

Ouch.  The e250 is a 2GB device;  it must be formatted as FAT.  For larger capacities, FAT32 is the choice.

Most any answer you may seek for your e200 series is right here in the forums!

Running Rockbox makes things a little different, but remember, the USB connection is handled via the original firmware.  What happens when the e250 is plugged in?

The Nuclear option is to reinstall the firmware using Recovery Mode.  There is one major warning that must be heeded:

When connected in Recovery Mode, DO NOT attempt to format the device using Windows.  It will erase critical data!

Check out this thread.  In the thread, I recommended version .18 as the formware, you can interchangeably use the final .24 version, both releases will work fine.  Following recovery, you can then check into reinstalling Rockbox if desired.

Bob  :smileyvery-happy:

is it the same process for the E250v2?

@skullabyss wrote:

is it the same process for the E250v2?


e200series v2 firmware & instructions. Don’t use the UIpdater.

By the way, there is no dedicated ‘reset’ button. To reset the device, press and hold the power/menu/home button (at the 1 o’clock position relative to the scroll wheel) for approx. 20 seconds.

Hi i own an e250v2 device and am having problems as it wont switch on, any ideas on how to re-set the device.It does respond when putting it for charge but still does not switch on!

Does your e250 show the “connected” icon when plugged in,and then go blank as soon as it is unplugged?

When plugged in, the device receives power through the USB port.  Look in the upper right corner of the display for the wee battery icon.  Do you see any activity there?

The battery is removable in the e200 series, so it’s possible to simply replace the battery module, or there might simply be a dirty contact between the module and your e250.

First, test if the device is OK by using a basic USB AC adaptor.  If the e250 doesn’t “see” data on the USB connection, as when plugged in to a computer, the front controls will work normally.  Connected to a computer, the controls are ignored.

If it operates fine with power supplied, unplug, and see if it suddenly dies.  Battery modules are available on the internet for great prices.  When removing the back cover, you’ll need a Phillips #00 screwdriver.  Be careful not to lose those little screws!  The battery drops in just like in a mobile phone.

As a last thought, if you use a pencil eraser, you can lightly clean the three contacts to see if your issue is a simple dirty pin.

Bob  :smileyvery-happy: