cant play loaded songs

alright i have a c240 w/ 1gig micro sd card

wmp 9 sees it fine and i can load to internal memory or the card, except when i unplug it its says i have ‘no songs.’

then when i plug it back in in sees all the songs i just loaded

i have 01.01.05P firmware so no usb/ MSC mode right?

do i need to upload different firmware?  which seems complicated, how to video links dont go anywhere for me (go to blank page)

manual says files wont be visible in dropped into data folders rather than media folders. i dont really know how to tell the difference just have the usual music,photo, playlist, record folders. 

songs are .mp3’s

i’m fine with using wmp player to upload songs.

i’ve tried formatting.

I had a c200 which froze on me and wouldn’t boot past the first screen.

when i go to safetly remove my computer doesn’t see it so i dont think i “broke” it by unplugging it.

would love it if someone could renew my faith in this company via a simple solution other than returning it.


What file type are your songs?  from my experience, iTunes stuff doesn’t generally work (and WMP doesn’t play it anyways) and that’s stuff like .m4p and stuff like that.  However, .wma, .mp3, and .aac should all work.  Check the file extensions.

What the manual means is that you can’t just put songs on it going straight to the folder on My Computer or something, you have to use a media player, which it sounds like you did with WMP. 

When my player freezes, I pop out the battery and put it back in, and that’s worked to unfreeze it every time.  I’ve had it stuck on the startup screen before too, and this method worked for that as well.  Oh, and don’t worry about the ‘safely remove’ thing, you don’t really need to use that, it’s just for things like if you have a big external hard drive connected and stuff like that. I never use it and nothing’s ever happened to my mp3 player, flash drive, etc.

thx for the response but i’m afraid it was no help.  perhaps I was too vague.  i’m loading mp3 files into the sansa via wmp, however the player doesn’t “see” the songs. It gives me the ‘no song’ message.  Then when I plug it back in wmp shows that the songs I loaded are there! 

nm i finally got wmp player to update alls well