Can't format or reset Sandisk Sansa Sport

I tried to erase this player in linux

and then Linux says:

org.freedesktop.UDisks.Error.Failed: Error creating partition: helper exited with exit code 1: In part_add_partition: device_file=/dev/sdb, start=0, size=4081057792, type=0x0c
Entering MS-DOS parser (offset=0, size=4081057792)
looking at part 0 (offset 0, size 0, type 0x00)
new part entry
looking at part 1 (offset 0, size 0, type 0x00)
new part entry
looking at part 2 (offset 0, size 0, type 0x00)
new part entry
looking at part 3 (offset 0, size 0, type 0x00)
new part entry
Exiting MS-DOS parser
MSDOS partition table detected
containing partition table scheme = 0
got it
got disk
Error: Can’t have a partition outside the disk!
ped_partition_new() failed

Then after that player says: File system error,

reset or format player.

Windows won’t format it. It detects sandisk as an hard drive, but

won’t format it. So it’s frozen now.

This same happens with sandisk sansa Jam.

Then I had also Sandisk sansa clip and it worked

always well with Linux (xubuntu).

Any suggests? Thanks :slight_smile:


in that case the player seems to be defective and needs to be replaced

here you can open a rma request

How to get a useless Sansa Clip working again

from user XSCD, 10-16-2008

  1. Reformat the Sansa Clip’s flash memory and install a FAT32 filesystem. You can reformat it in Linux using Gparted, but the Clip still won’t work because the Clip wants the exact settings that Windows uses when it formats a blank disk. However, reformatting the Clip in Gparted will serve the purpose of ensuring that it absolutely won’t work nor be recognized by a Windows machine. So go ahead and do that once if you like. Then plug the Sansa Clip’s USB2 connector into a machine running Windows or Vista. Then use Windows file manager (Windows Explorer) to try to open the drive letter of the Windows-detected USB device. Windows will give an error message saying the drive is unformatted, and offer to format it for you. Choose FAT32 filesystem and UN-check “Quick format.” Then let Windows format the Sansa Clip’s flash memory.
  2. After the Clip is formatted in Windows, remove it (“safely remove hardware” icon in system tray, followed by disconnecting the USB cable). Then go to and download the “Sansa Updater.” This application is for updating the firmware of already working Sansa Clips, but believe it or not, it can also completely restore the firmware and directory-structure and files that the Clip needs to run. After downloading and running or installing the Sansa Updater, close the program. Then plug the Clip back into Windows. It should be recognized and the Sansa Updater program may automatically launch. If not, then find the Sansa Updater in the Start menu, launch it and follow its directions. It will search for your Sansa Clip, then download the latest firmware, then restore your used-to-be-useless Sansa Clip to a pristine, factory-approved, completely updated state

Here is a link to the Sport Clip Updater Software: FW 1.29

Thanks for your answers!

Problem solved:

I opened computer management
in Windows XP and connected sandisk
sansa sport to my usb port.

Then I created a new FAT partition for it.

After that I managed to go
in sandisk sansa settings, which I couldn’t
do before and then I formatted the disk from

Thank you!