Bricked Sandisk Clip Sport


I bought this device unsealed off of eBay not too long ago, and tried setting it up in Linux Mint 21, but it wasn’t being recognized in my directory, despite it being listed in the Disks utility. With Windows being the dominant desktop OS, I’m guessing the device was made at a time where Linux had less support than it does now. The first thing I did was searching for a solution on the web, and after reading about a similar issue on the Mint forums, I formatting the device using GParted, only to get an error message and the device to stop working until I plugged it back in. I tried repeating the process, only for the same problem to happen again. Then I tried using the MKUSB utility just now, and I think that accidentally bricked it because when I tried using it again after it still wasn’t being recognized, it wasn’t being recognized in the utility itself. How can I unbrick it and finally get it set up?

Hi @Tiger1994,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

The main memory bank has a hidden partition that normally allows the player to recover itself and to create the required system folders and to generate the databases after you eject the usb connection.
Likely you deleted this critical hidden partition. I have never seen a way to recover this hidden partition within this user forum.