Can't access from macbook yosemite.

I just got my Wireless flash drive 64gb. It works fine on OS8 but when I try to connect wirelessly from my macbook (after connecting to the devices wifi network) it just hangs on the webpage. after a while it might go to this error message “cannot connect” with a picture of the stick on the webpage.

I tried the default safari browser and I also tried firefox but no go.

I turned off my ad blocker also.

I reset the device but that didn’t help either.

I chatted with the help desk but no help there.

Can anyone help?


You can try to update the firmware manually of the drive because you might have a previous version installed or this version is corrupted for some reason and so its not working properly.

So i would suggest to try the manuall firmware update of the drive:

Thanks, that’s how I updated the firmware when I did it, I wasn’t aware that there was any other way.


In that case if the firmware update does not help also i would suggest to contact the support and provide pics of the message you get in order to get clarification on the issue.

Was on with support twice, they had no idea what to do. They suggested I get a new one.

I did and it didn’t help.


Sorry to hear that but if even the support cannot find a solution and the new drive does not work also then i would suggest to contact them one last time and ask for clarification about the issue. I think it would be very interesting to hear their opinion on the issue and maybe they will come up with a nice solution