Wireless Flash Drive will not connect after 3.3.1 update

I updated the hardware on my Wireless Flash Drive when promted to do so in the app today . Now I am unable to connect to the drive. I have reset to factory settings and manually installed the update again following provided instructions on the website but nothing is working to restore connection to the drive

Is there any clean install of the software and settings that came with the drive  - I don’t mind if any files are lost in the process. Urgently need support!

Factory reset and reinstalling the FW is really all you can do to reset the drive. I have WFD app version 1.5.1 and FW 3.3.1 and done see any issues. What type of device are you using with the WFD? Have you tried forgetting the network and reconnecting and force quitting the app completely? If you can let us know more about how you are connecting to the device and any error you get when trying to connect it would be helpful. 

I was able to connect to the drive. I was connecting to the drive through my local network and the update somehow had this configuration corrupted. Once I connected directly  to the wireless network drive’s wifi I could access the drive again and then re-configure things to work with my LAN again. But thanks so much for getting back so promptly - greatly appreciated.

I am experiencing the same problem on on my i phone 4s since updating a firmware update this morning. My other ios 7 mobile devices (iphone 5 and ipad 3) continue to work fire and did not ask for a firmware update.

It is frustrationg and there does not seem to be anything that I can do. I have forced the app to close, deleted and reinstalled etc and still no connection.

Any ideas…


do you ahve any preferred networks set up in the WFD app internet connection settings? If so try forgetting the networks and reconfiguring them.