Cannot load music on external sd card

I have tried everything to load music onto the external 16gb sd card I bought for my sansa clip +.  I bought it from Amazon so its legit.  I tried dropping onto the folders and it always tells me I dont have permission.  I have re-formatted, shut off, put the card in multiple times.  I dont get it.  Please help.

It may be a defective card. I suggest exchanging it for another one.

You didn’t happen to have use it in a cellphone, did you? Sometimes a cellphone will put code onto a card and you’ll get the “don’t have permission” message.

Kinda sounds like a computer pemission thing. If you’re running Windows, what does it say when you right-click on the drive in Explorer and select Properties?

Does the card work if directly put into your computer, or do you have the same issues that way as well?

I have the same problem.  Clip+ 4G purchased from Amazon.

I’ve tried this with two different 2G microSD cards.  Both have been formatted multiple times, both work in my PC and in my cell phone.  

I’ve tried drag & drop when the cards are connected to my PC directly - this works fine; however, as soon as I install either card into the Clip, one of two things happens:

  1.  The Clip says that the card is installed, but has 0 bytes used and 0 bytes free

  2.  The Clip says that the card is installed, Used & Remaining Memory looks correct, but when I browse the music, the external card is empty

I’ve freshly formatted the cards, and installed them into the Clip.  Most of the time, the Clip registers the card as a 0 byte card and I cannot do anything with it.  However, on the few occasions that the Clip actually recognizes the card and says there is 1.8G freem memory on it, I cannot copy any files to it; I get a “you don’t have permission to add files” error

This is nuts - I’ve spent hours on this.  Googling shows that it is a major issue with the Clip+.  SanDisk really should have dealt with this issue by now.

And for the record, I am using SANDISK’s memory cards in SANDISK’s player - should work…  

Are you still within the player’s warranty period?  If so, I’d contact SanDisk for a player replacement.

Until recently the Sansa clip + has been a great machine to transfer my music.

I have a similar problem to dwoodard.

Synchronising from windows media player to 32 GB micro SDHC memory card in my Sansa clip +, it shows the transfer has been made. But when I disconnect the Sansa clip + from my computer after refreshing the MP3 it does not show the albums have been transfered.

To test windows media player I made the same transfer to a 8GB memory stick, transfers worked!

What have I done wrong?

Kinda sounds like a computer pemission thing. If you’re running Windows, what does it say when you right-click on the drive in Explorer and select Properties???

@blackrosegul wrote:

Kinda sounds like a computer pemission thing. If you’re running Windows, what does it say when you right-click on the drive in Explorer and select Properties???

Is there an echo is here? :confounded:

Earlier in this thread Tapeworm wrote:

Kinda sounds like a computer pemission thing. If you’re running Windows, what does it say when you right-click on the drive in Explorer and select Properties?

Congratulations on mastering the fine art of copy & pasting. Keep practicing and maybe you’ll be able to do the Control + Alt + Delete key combination without help.