Cannot format the Sanza Fuze into my PC

I recently purchased a sanza fuze mp3 but my computer does not recognize the device. I have a windows vista. I want to be able to format the mp3 into my pc so that I can use Windows Media Player to download music, if possible. Thanks.

  1. You don’t need to format the player to work with your computer or Windows Media Player.
  2. MTP mode can be problematic (and also the infamous Auto Defect), so I’d suggest setting it to MSC mode for the easiest connections (Settings > System Settings > USB Mode).
  3. Using MSC mode there’s no need to use WMP to transfer music files to the player. You can simply drag & drop (copy & paste) as you would with any other files on your computer.

The problem is that my Sanza Fuze+ player is not recognized by my PC (windows vista). Also the following message keeps popping up with a yellow exclamation point: “USB Device Not Recognized One of the USB devices attached to this computer has malfunctioned and windows does not recognize it. For assistance in solving this problem click this message” it continues to do this even when the device is not connected to the computer. I have tried everything but nothing seems to be working.

Have you tried switching it to MSC mode as suggested?

Or a different USB port or computer?

I have tried swiching it to MSC but that did not work. I also do not have a different USB port. Although, it did work on another computer but it does not belong to me.

You only have 1 USB port? Must be a really old computer. Most in the last 10 years or so have at least 4-6 USB ports, but yet you have Vista installed on it?

Is it a USB 2.0? If not, that may be your problem.

I don’t think a USB 1.0 vs. 2.0 problem would cause an error message like this, since USB 2.0 devices are supposed to be backwards compatible to USB 1.0.

Perhaps you have a bad cord? That would explain why you are getting this message even when disconnected. I’ve had that happen with a USB mini cord for my father’s blackberry. As soon as the cord was plugged in, the exact same message would pop up, even if the cord wasn’t connected to anything. Edit: I guess it pays to read posts carefully, as I  just now noticed that your device worked on another computer. Therefore, assuming you used the same cord, I’m guessing that’s not your issue.

Or, does this happen regardless of whether the cord us plugged in or not? If this is the case, the USB port itself may have malfunctioned. You could buy an internal PCI or PCI Express hub, and use that instead. Please note that if you use an External hub, that probably won’t solve the problem, since you will be hooking it up to the same problematic port.

One thing I find interesting is that, unless I’m mistaken, even older computers tend to have an even number of ports. Perhaps you meant you only have one port available, as the other ports are being used?