Computer will not recognize the fuze

    My Sansa Fuze works great until I need to plug it into the computer. When I try to plug it in, the screen on the fuze turns white and the computer says a malfunction has occured  with the device. To get rid of the white screen, I have to hold the switch for 10-15 seconds. When I turn it back on, the refreshing media screen appears for about 2 minutes. Sometimes it takes as many as 5 minutes to refresh.

    I tried the suggestion to turn the fuze off, slide the switch to hold, press the << key and connect to the computer. When I did that, the connected screen comes up, but the computer still does not recognize the fuze.

    The fuze is currently in Auto mode, it is fully charged, version V02.03.33A, I have 2702 MB free, using Windows 7 and WMP 11. Thanks!

It’s best not to use the Auto Defect USB setting. Easiest connections are obtained using the MSC mode, but depending on how your music was transferred you may want to format and re-load everything in this mode. Otherwise, if the unit auto-connected in MTP mode, you won’t be able to see or access the files while in MSC.

Try the MSC connection first though . . . no need going through formatting and re-loading unless it’s necessary and the MSC mode works for you.

   When I tried the MSC mode, the computer recognized the fuze, but about 30 seconds later, a box comes up that says “your portable player is working on another request. Allow player to complete current task and select transfer to portable again” then the fuze screen freezes.

   When I tried in MTP mode, a box comes up that says “device driver software was not successfully installed”  and the computer does not recognize the fuze.

Try MTP mode, connect and even if you get the error message go to Device Manager. (You’ll have to find the path in Windows 7). You’ll probably see a yellow triangle with an exclamation point. Right-click and Uninstall, then reboot, then try connecting again.

If that doesn’t help, try reinstalling or rolling back Windows Media Player. 

Then go to MSC, look in Device Manager and uninstall what is probably a USB controller with the exclamation point, and reboot. 

The idea is to get Windows to reinstall clean shiny drivers for both modes. The MSC is the standard generic USB driver, though, so that generally works without uninstall/reinstall. 

   I uninstalled the driver for MTP mode but when I plugged it back in after the reboot, a box came up that said ‘device driver software was not successfully installed.’

   In MSC mode, there was no exclaimation point in the device manager. The fuze is working great in MSC mode.

I’m not familiar with Windows 7. But I would suggest you reinstall or downgrade (to 10)  or repair Windows Media Player, because that’s where the MTP drivers are.

You can also look on the Microsoft site for an “MTP Porting Kit” for Windows 7. 

Black-Rectangle wrote:

I’m not familiar with Windows 7. But I would suggest you reinstall or downgrade (to 10)  or repair Windows Media Player, because that’s where the MTP drivers are.

 

You can also look on the Microsoft site for an “MTP Porting Kit” for Windows 7. 

You don’t need an MTP porting kit for Windows 7 …MTP support is built in to Vista and now 7. For that matter, why is srhcttl using WMP 11 with Windows 7, when it comes with WMP12? It takes some work to downgrade to WMP11, and I don’t know why you would want to…WMP sucks (and I don’t think it is possible to go way back to WMP10) .

I’m thinking Tapeworm was on the right track…format the sucker, reinstall the firmware, switch it then to MSC mode in the settings, then reload the content.

As I said, I don’t know Windows 7.

I do remember seeing a post on here somewhere in which someone found an MTP Porting Kit for Vista, and it helped. Which surprised me too. 

If Win7 wants WMP 12, perhaps having 11 is the problem. (I did also suggest reinstall and repair.)

But Marvin and Tapeworm are right. Use MSC mode and have one less problem. The only thing you’d need MTP for is music with DRM garbage in it. And that’s best avoided as well.  

My mistake, I am using WMP 12. Since the MSC mode is working well, I will stick with that. Thanks for your help!