cannot delete files in MTP mode on external card....

Hello all,

I use to work with my Fuze in MSC mode… I copied some albums with Window Explorer.

On my PC now, I can access to all files on internal memory, but for any reason, I cannot access to the Sandisk Microsdhc card.

I discovered that I can access to them only in MTP mode (though I never changed the mode on the player…), but that is another problem.

I tried to delete them.

So I’m in MTP mode on the player, plug it on the PC. When I select the “External Card”, I see the artists/albums/songs.

I deleted all artists folders.

The poperties show now 14.7 GB free for 14.8 GB total.

Unplugged the player, the database is refreshing…

Plugged the player, still in MTP.

The songs are still there !!!

I have no autosynchronization with WMP, as I never use WMP and as I said I never use MTP mode (only this time to try to solve my problem).

What can I do to delete definitively the files in order to go back to the MSC mode ?

Thanks for your help…

You can go into My Computer and under Removable Disk, format the card.  Drive letters can be different for each computer, but it’s normally the one just underneath the drive that shows up for your fuze.  Right click on the card’s drive and select format.  If your card is over 2 gig, do a full format with FAT 32.

Well, thank you fro answering.

If I stay in MTP mode, of course I have nothing in My Computer / Removable Disk.

If I change to MSC mode, under removable disk I have SANSA FUZE and external card.

I can access to Sansa Fuze internal memory, but cannot access to external card, both with left or right clic, so I cannot format it.

I have an error message, saying sometimes ‘plesae insert a disk in drive g:’ or ‘cannot read because of a i/o error’.

PLease note that the player access correctly all the files, I can listen to the music, but I cannot add new music.

firmware version is 1.02.26 and same thing with 1.02.28…

That’s something very new to me as I use th Fusze form one year and the microsdhc for 6 months without problem. I don’t know what happened…

You can try looking in device manager for an exclamation mark in one of the usb drivers.  If there is, then you’ll need to reinstall it.  That may clear up this issue.  Since you tried two firmware versions, then it can’t be the firmware causing it.

Another thought, have you tried to use a different usb port (preferably a rear one) or another computer?  I believe that I read in another post that a usb port with too low of a charge can cause connection issues.

Try putting the card in a reader, or in a different device (phone/camera)  and see if you can access it.

Here is the results of last tests…

I have no driver problem, according to the device manager.

I can read the card trough the Fuze, and also through my phone.

As soon as I plug the card on my PC through : FUze (MSC mode), reader, or phone, I cannot access it; still same kind of effect : insert a disk in the drive, or i/o error, or sometimes… nothing, but still no driver problem and no message in teh event viewer.

Last thing, very strange : if I delete the music through the Fuze directly (which is very long, file after file…) : I deleted an entire artist / album ; so it’s not in the Fuze through Music / Artist / album . I plug the Fuze on the PC (again in MTP mode, no way otherwise…) : the artist / album is back again in the directory. I unplug the Fuze, Database refreshing , the artist / album is still on the Fuze’s card, without any copy (so no synchronizing with WMP).

I’m completely lost!!!

Thanks for your help… 

And, I forgot to tell, I tried on 3 differents PC : 2 XP and 1 Windows server 2003… I will try today on Vista…

Message Edited by Frankie on 10-17-2009 08:56 AM

I think what has happened is that MTP has imposed its own file system on the card, so it’s only readable via MTP. (Maybe your phone also has an MTP option–mine does.) I use MSC, and I was experimenting with MTP, and this happened to me and was driving me crazy.

Eventually, I figured out a way to format the card, and since then I have dealt with it only in MSC mode.

But I don’t remember how. Is there a Format command buried in Windows Media Player somewhere? Or can you do it in your phone? 

You could also, just for the heck of it, try to roll back Windows Media Player (in Add or Remove Programs) in one of your XP computers, then update to 10 or 11 again. The version that was built into XP is WMP 9, which doesn’t connect via MTP. I have no idea what WMP is in WIndows Server 2003, but it might also be before WMP 10. 

Message Edited by Black-Rectangle on 10-17-2009 08:25 AM

Unfortunately, nothing possible with WMP…

After one or two thousands of tries, I managed that…

PLug in MSC mode. Open DOS box.command Format f: /FS:FAT32 /A:32K

After a while, the formatting began… (Happy face !!!).

After 100%, I got this message :  “Invalid support or incorrect track 0 - Unusable disk”  (translation from French, not sure it would be the exact message in English, but I imagine you understand…)

I tried two utilities, one from HP (says Write Protected !!!) one from Panasonic (not answering after 10 minutes…).

I don’t know what to do. 

Have you tried running a checkdisk from the command line?  There’s posts here that describes how to do that.  If all else fails, I’d call sandisk tech support.  Even cards have a warranty.

Finally, I decided to contact the technical support.

From their point of view, thereis nothing we can do except changing the card (I do not think he searched a lot; after 3-4 questions and 3 minutes he explained how to return the card…).

Anyway, They change it as it is still under warranty.

I hope this won’t happen with the new one !!!

Thanks to all…