Can't delete off microSD card after firmware update

I have a 8gb Fuze, with a Sandisk 16gb microSD card. This had been working reasonably well, until I updated to the new V02.03.31A firmware. When I did the firmware update, I had formated both the internal and external memory, did the update, and then reloaded all both the internal and external devices. This all went fine, and I have no issues playing songs from the external card. However, when I am in sync mode in WMP (MTP mode), it will not allow me to delete from the external card any more. I can delete from the internal memory fine. This did not seem to be an issue before the update, and as I said, it plays all the songs fine.

Anyone ever run into an issue like this? I would like to change around some of the music on that card, but I hate the idea of reformatting it, as it takes a long time to reload 16gb of music!


Message Edited by TomJensen on 05-03-2010 06:17 PM

Are you sure the music wasn’t added to the card in MSC mode? WMP won’t see that.

WiMP, in all its complexity, can be a real pickle.  Be sure that you are selecting the correct “venue” when in sync mode.  WiMP11 does not change the Sansa icon when in internal versus external memory; you need to peek at the listed capacity below the icon, and select Next Device if needed.

Be sure that the External Memory is highlighted in the tree at the left of the screen.

There’s always the Nuclear Option: Windows Explorer.  Simply navigate to the External Memory, then pull the files manually.  Since I use WE often, as well as WiMP11, both methods work well.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 02-25-2010 07:50 AM

Hi neutron_bob

I am aware of the need to switch “devices”, such as WMP labels them, when working in sync mode. But that makes me wonder. I see the device panel on the right, where I would add songs to sync. On the left is the panel with the devices listed, to view contents. I can select the 8gb internal memory, view what’s on it, and delete songs or albums just fine. But if I select the external memory card, view it’s album/songs, I can’t delete anything. The ability to select and delete items in the album or song view does not have anything to do with the device selected in the right hand sync panel, does it?The two operate independantly?

As for the suggestion given above, to switch media managers, I have to ask, would the selection of media managers actually make a difference in what the system thinks is read-only or not? For better or worse, I understand WMP, and while recognizing that it’s not necessarily the end all of media players, it has to this point worked well, and I’m not really excited over the idea of changing.

No one has ever encountered this particular issue before?

Do you have another card somewhere (maybe in your phone?) that you can use to test if the issue is with the card?

Are you 100% certain you are in the same USB mode you were previously?

Have you tried using a card reader?

I’ll apologise in advance if I’m asking a question you already answered.