C140 Unique Problem / Crash

I have an old Sansa C140, it suddenly just stopped working properly. When you start up the player the Sandisk screen and logo appear, then it briefly displays “No Space for DB / Please Delete / More Than 4.0 MB”. After that it goes to the Language selection menu and shows a completely empty player. You can navigate the menus and change the settings, but you cant do anything else at all. My laptop (vista) recognizes it and shows it as TCNAND0 465MB Free of 973MB. I’ve tried doing a format and it runs and the laptop says format complete but the player just repeats the “No Space >…” again and nothing changes. What am I doing wrong and what can I do to revive this dead player? If I try and copy an MP3 onto it says “Synchronizing …” but the file never finishes copying. When I cancel the copy and disconnect the player it shows “Initialize_FileSystem / Fail”, before going back to the Language menu again. It looks and acts like its running properly but empty (and ODDLY enough the radio still plays!) but anything to do with the files or file directory is completely unacessable.

You can try to format the player under disk management and connect your device on force MSC;

-Place your player on hold

-Remove the battery and press the center button while conencting it to your computer.

-Once it is detected follow these steps.

http://kb.sandisk.com/app/answers/detail/a_id/107/kw/how%20to%20format%20in%20disk%20management/r_id/101834 

I tried all the methods available on the forum and knowledge base, including firmware updates and formats in both modes. I just ran through the same thing with sandisk support over the phone before they told me they could not help me since the product is more than a year old. The player WAS bought a while ago, but had to be replaced after 7 months when it started getting hung in the middle of songs and acting improperly (I was never told the cause of the issue but was issued a new device), it worked fine for almost a year after that before the most recent problem began occurring, and I have spent the past few months trying to hunt down fixes and resolve the issue. The device is not used during running or any vigorous or hazardous actions, its primary function is music and notes during my hour commute to and from work (public transportation) each day. It has never been dropped, hurt, or abused in any way. Given that and the fact that the issue seems to be the corruption of their own software, if feel that sandisk should be willing to repair or replace the defective device. Can anyone suggest any further recourse, or have come out with a positive solution under similar circumstances? This has obviously shaken any credibility i put in sansick products (which I had previously recommended to and bought for others, which I will never do again under these circumstances), so I am hoping some kind of solution can be resolved. Thank you.

Try going to wikibooks.org and doing a search for c140.  Go to the bottom of the page and follow the link to the firmware.  Download and uncompress this .rar file.  This usually fixes just about everything.