Serious problems with c140

I have a Sansa c140 since some years now, I used it mainly as an USB drive, for storing/moving files, and sometimes I’ve used it to create bootable OS images, for linux ubuntu for example, and it worked well. But then one day I was trying to create one of these bootable linux into the player, and I don’t really remember what happened, if my computer crashed or the software I was using hanged, anyway the result is that the mp3 player capacity seems to be FULL but the bootable image didn’t got created 100% so the device wont boot. So I tried to reformat it or delete some files, but the player wont work. This is whats happening:

First when I turn it on (takes like 3 minutes to finish loading the sandisk splash), it shows me the message: “No Space For DB, please delete more than 4.0MB”.

So then I set the USB settings to MSC, and I plug the cable in, in linux (ubuntu 10.04), nothing happens, I don’t get it recognized like an external disk like it use to happen. So I can’t delete or reformat from linux.

Then I went to a Windows installation, I plug the player cable and it does seem to recognize an external disk, but explorer.exe hangs when I open “My Computer” folder and it never unfreeze, I have to unplug it and relaunch explorer.exe to continue, I’ve also tried to access the device from a  CMD window, it will hang also.

So I don’t know what to do now, how can I get this device reformatted so I can use it again?

ps: I never used the “Auto detect” USB mode (MTP), but I think it algo hangs in the same way.

I installed a Win 7 virtual machine, and connected the player in MTP mode, now I can see the Internal Storage and format it, right now it still says “Formatting” both in Win7 and in the device screen. I will post an update here if everything goes well.

Finally after trying to reformat like 100000 times, the player now is half empty and its picked up much faster, I guess everything is cool now ill try to finish reformatting.

Still no luck, i dont even know how the hell it got formatted in “half”. The player is now recognized in all OSes, both MTP and MSC.

Disk utilities on any OS show 1GB capacity, but when checking right click > properties it shows only 541MB free, and there’s nothing inside it when I browse it.

I tried tons of apps like bootice, gparted, etc. Nothing can create a partition on it.

“fdisk -l /dev/sdc” shows no partitions, this is the output:

Disk /dev/sdc: 1020 MB, 1020887040 bytes 32 heads, 61 sectors/track, 1021 cylinders Units = cylinders of 1952 \* 512 = 999424 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x00000000 Device Boot Start End Blocks Id System

“sudo sfdisk -l /dev/sdc” shows:

Disk /dev/sdc: 1021 cylinders, 32 heads, 61 sectors/track Units = cylinders of 999424 bytes, blocks of 1024 bytes, counting from 0 Device Boot Start End #cyls #blocks Id System /dev/sdc1 0 - 0 0 0 Empty /dev/sdc2 0 - 0 0 0 Empty /dev/sdc3 0 - 0 0 0 Empty /dev/sdc4 0 - 0 0 0 Empty

I’ve tried creating partitions with both fdisk and sfdisk, and when I do “-l” again i get the same empty output. ( here’s more info about how i tried to create them )

I am so pissed right now I want to smash the player on the floor. 

Could it be that there’s a hidden partition on the >400MB of used space? I tried a lot of partitioning apps including the windows built in and nothing pick it up, it just shows one partition with the full 1gb size.

Sandisk should provide some utility to restore everything inside the players, right now I am hating sansa and I don’t think I would ever want to buy another product from it.

Please if someone has some ideas to try let me know.

The c100 series is an ancient, entry-level player. If you got several years use out of it, let it go and get a newer device. And if you want to use something as a flash drive to shuttle files back and forth, etc, then get something designed specifically for that use; like a flash drive or even a simple memory card with a card reader.