C100 - Format Could Not Complete

I can’t delete files off my sansa so tried to format it but get error message ‘format could not complete’.

Can anyone suggest a solution?

thanks in advance


Message Edited by MrSmileyFace on 10-03-2007 06:06 PM

Put the player into MSC Mode, and try a disk management format… it works wonders!

Thanks for your reply, but this didn’t work for me.  Via Disk Management it seems to reach 100% in formatting but says it did not complete successfuly.  I did it as FAT as I read somewhere but should I try FAT 32?

I’m having exactly the same problem.  I’ve tried both FAT and FAT32, and get the message “Windows could not complete the format”.  Is there a way to do a hard reset on these things?

Suggestion - switch to MTP mode and reformat using WMP.

Tried that before switching to MSC mode.  WMP appears to complete the format successfully, but all songs remain on the player.

probably needs to get replaced. if you contact sandisk through email about your problem, stating all those things you tried, they should be able to replace it for you. In your best interest to fill out the registration information as well, to save yourself some time.-

Already in communication w/ Tech Support.  They’re pretty much useless (based in India, I suspect) and keep replying with canned answers about reformatting in WMP and using Disk Management to reformat.  I swear these guys don’t know how to read, and just scan for a few keywords before launching a canned reply.

bear with it, tell them you have tried all the steps. Im sure youll get it replaced

Well after a few go-arounds with Tech Support, I finally got an RMA.  I was pleasantly surprised to also receive a postage-paid return label – now _ that’s _ service.

Anyone know how long it typically takes to get a replacement?


anywhere from 7-10 business days from when you send yours out to them. Usually the shorter of the two. atleast thats how it was during my rma

Had the exact same problem, couldn’t remove their pre-recorded music, but then when we were plugged into the USB, PC wouldn’t recognize it.  I got tech support (SanDisk) and was super pleased with their service, little slow, but that was okay.  After several attempts, finally they told me that since it was still under ‘store’ warranty (30 days) that I should return.  I purchased through an email service (don’t know if I can give their name, so won’t) and they shipped me a new one that day!!  UPS, no less!!  As soon as I got it…three days later…I put the defective one in the box and mailed it back; they even gave me credit for MY postage.  Nice of that company too.   Don’t know about replacing from the company, but from my place of purchase, I was/am SUPER pleased.


Good Luck!