Burning Image files to Sandisl Cruzer 8GB

I have been trying to install Dam (not the way it’s spelled) Small Linux to a SanDisk Cruzer 8GB for the last couple of weeks with no luck. In fact, I have tried to install many Linux distros with similar results. In the DSL live CD is a tool for installing to a USB with very clear instructions. Attempting this gets the error: ‘mount: wrong fstype, bad option, bad superblock on /dev/sda2, or too many mounted file systems’.  Coming at this problem from another angle, I used the program Unetbootin in Kubuntu 12.04. First it asked me to erase the disk, which I attempted to do and failed. I went to the KDE partition manager, repartitioned the entire disk and formatted to FAT 32. Unetbootin now refused to accept the drive as mounted. Attempting to just copy the file results in “wrong URL” error. I have posted on numerous other forums and the consensus is that the U3 tool prevents burning image files to SanDisk usb drives and prevents them being used as boot devices. Do I need to buy a different brand of drive? Is there a workaround?


  1. U3 devices haven’t been made since 2009.  If this is a new USB drive it doesn’t have U3 on it.

  2. U3 drives can be booted.  I have two and I boot both.  One is FAT32, one is NTFS and BOTH still have U3 on them.

  3. IF you have a U3 USB drive make sure the password protection is disengaged to write to the writable portion of the drive.

  4. IF you have a U3 USB drive write DSL or whatever version of Linux you want to use to the writable portion of the drive and not the CD portion.

Ed D,

 Thanks for the response. I’m not exactly sure what you mean. When any of the tools I’ve used to do this partition the drive, they partition a ‘swap?’ file (small), then a larger space (usually in FAT32 or ext3). I’ve always assumed the load went there, but don’t know for sure if they have specified such.



Ed D,

PS: these are brand new disks purchased at a local chain on sale.


“these are brand new disks purchased at a local chain on sale.”

Then they do not have U3 on them and any old U3 software will not work on them.

“Attempting to just copy the file results in “wrong URL” error.”

Well my Linux knowledge is limited to using an app or two on Live CD downloads so I can’t help you much with Linux but a “wrong URL” error implies to me that you’re trying to format the drive remotely and I don’t think that’s right.

Good luck with your project.  If you find the solution let us know.  I don’t think it’s a Sandisk drive problem.

Actually the “wrong URL” message appears when I try to drag the file to the USB stick icon in my file manager (called Dolphin) in Kubuntu (works the same way as in Windows).  I was hoping that someone here could give me some pointers about the basic architecture of the sandisk itself, and if it indeed was formatted by the company to be non-bootable with Linux.  This was suggested in another forum. I was also hoping there might be sandisk developers lurking here who might know something of this issue.

Anyway, thanks for your help and I’ll just keep working on this issue in KFN and UFN and see if something can be worked out. If I figure it out, I’ll be sure to post results here.

All the SanDisk USB drives are formatted in standard FAT32 format because it is the format recognized by the most equipment.  What it is now that you have reformated I have no idea.

And don’t be mislead by wild speculations.  Just because someone posts doesn’t mean they know what they are posting about.  And that includes me.  :smileyvery-happy: