battery is dead, not readable, can't charge. mac os x 10.4. solutions?

took my fuze on a trip back home and i guess battery died. I had no problem before with my computer reading the fuze and adding music plus charging. now since the battery is dead i can’t turn it on and my comp wont read it or charge it, when i plug it in to the computer nothing happens except when i mess with the on switch the error message will pop up just saying its not readable. nothing comes on the screen and no music plays when hocked up to speakers.  i have a mac osx 10.4  

any ideas?  


Try forcing the MSC connection. With the unit off, slide the power switch down to HOLD, showing the orange dot. While holding down the << control, connect the Fuze. See if it’s recognized.

If not, your cord might also have gone bad–you could try a replacement. 

i have tried the force connection and the same message comes up that it is unable to read it. what can i do with the pop up message option? i have tried connecting it to another computer, it might have been vista or windows 7, forget the os but it said unsuccessful error. if the message pops up saying it can’t read it, would the chord still be damaged?  

Try charging it with an AC usb charger. After that, if it will turn on, then format the player using the player’s menu. Make sure the player’s USB mode is set to msc. Try to connect the player to your pc to reload music on it.