Battery charge sansa fuze


   I have purchased new sansa fuze now when i charge this it shows the charging icon for few minutes and then it disappears,this is a brand new sansa fuze and when i charged it for the first time it was showed the charging symbol until i disconnected it from the comp,but it did not charge it was the same charge point before i plugged in to charge.I am using this player in india and it was brought in U.S.Please suggest me the steps to troubleshoot this particular concern. 

Maybe it doesn’t show battery charging animation when its fully charged, so it means u can disconnect it from USB.


   Actually when i connect my player to the comp for charging intially it shows the charging icon and it starts charging for few seconds later the icon disappears and the charging stops.I have tried this with different comp and different USB ports its still the same.

Is it connected to the front USB port on the computer? Sometimes the computer cases’ cable is unable to provide proper power levels for USB powered devices, the USB port on the rear of the motherboard is a better option. My display stays on, and the battery charge “bolt” stays on the display, as the battery charging icon flashes relevent to the power level.

I tried connecting at the back of the systems USB port,its still the same it shows the charging icon for few seconds and the charging stops.

This is normal for a full battery.

I was also facing the same problem and i also bought from someone form us

force your Sansa players to connect in MSC mode(settings-usb mode-select msc} to your PC

For Sansa Fuze :
1. Turn off your player.
2. Slide the Power  switch on the right side of the player down until you see the orange indicator.
3. Press and hold the << (rewind) button 

  1. Connect the player to the PC with the cord while holding the << (rewind) button  . 

My Email is


Take your e-mail out… this is a Public site and spammers will get it. Use this sites Private message feature for that kind of information.

Thanks a million! After I followed your instructions, my laptop recognized my Fuse and “installed” it. The unit began to charge and continued normally.