bad firmware update

Just bought C240 1 week ago; new to this and learning device as I go; downloaded firmware update, sync’d too much material and overloaded memory; couldn’t clear memory, couldn’t even get to format function… level 1 tech support advice…“take it back and start over”

got a second C240, worked great, downloaded second firmware update when the balloon popped up not knowing it would remove usb function and could not access music files although they would play; folder options also show hidden folders but can’t pick to delete at a future time without USB function; tech support tried to send previous firmware driver but image load failed and now unit is stuck in request for recovery mode which only shows new firmware driver installed; advice from supervisor of customer service…“take it back” 

Why can’t tech support correct their mistakes? I will try the additional downloads they have promised in 24 hours to restore the second device but might take this one back as well and exchange for fresh unit which I WILL NOT MAKE THE MISTAKE OF DOWNLOADING UPDATED FIRMWARE, will just happily download in auto-play mode which syncs fine in WMP and I can still view all my files and delete as I choose…sure am learning alot with all these mistakes and am looking at the how to videos on the site as well.  I also requested Sandisk inform as to the nature of the new firmware update. Thanks for listening, folks…

question: how can I remove the firmware file now in my player when I can’t find any files for it hidden or otherwise?

Message Edited by MJ on 09-02-2007 02:46 AM

this has been posted in the “latest firmware update” thread at the head of this forum by one of the moderators, sansamonster.

ATTN: SanDisk has reverted back the firmware to 1.01.00 (as of 9/2/07)

Message Edited by sansamonsta on 09-02-2007 06:37 PM


However, I don’t know if triggering another update will put you back to this previous firmware or not.  If it does, you shouldn’t have any problems.  I never did the update.  I rarely have any problems with my player.  (the above firmware version is what I’m running.)

Problem solved !!!

Here are all the firmware revisions (I recommend 01.00.04 or 01.01.00):

Extract the mi4, font and ROM files using 7z unzip (you’ll find it on the net) and copy the extracted files into the root folder of your device in MSC mode and then disconnect it from USB. It will “upgrade” (or downgrade if you wish). If MSC mode is missing, put the player into Recovery mode by switching the HOLD on and hold down the record button for a few seconds.

Be sure to pay attention to the region code.
SansaC200 A 1_00_03.7z

A is America.
E is Europe.

F is Europe with FM

P is for Pacific
… Not really sure about the rest.

Once completed, the USB>MSC mode will be restored !!!


Hi, I took back the 1G red C240 before trying the fix and actually did better by getting a pink C250 on sale at BestBuy over Labor Day. It has the .00 version which seems to be on the C200 series players.  I’m glad to see they pulled it. I spoke with customer service supervisor and told him to take a look at the threads here and read all the problems. Didn’t see what the newer firmware did besides removing the USB choice. Thanks, I learned alot here because whenever I spoke with level 1 tech support to correct my devices the final advice from them was “take it back to Circuit City”…hmmmmmmmmmmmmm