Auto mode is not working properly

Recenly my 8GB Fuze had the dreaded white screen of death, so I sent it Sandisk to have a replacement shipped. The new fuze works fine but the major problem that I am having with it is adding music to it. Everytime i hook it up via usb, it reads normal for a while, but then it disconnects. For example I have it hooked in, and then after a few seconds, it acts like if i disconnected and then reconnected it again. It wont even charge. It does the same on MTP mode, but on MSC mode it works fine. On MTP mode in my device manger it lists sansa fuze but with the little yellow question mark next to it. I try to install drivers again, but the problem persists. Any ideas?

Have you got any other programs running that might interfere? See this link.

Are you plugging into a USB port at the back of your PC (desktop)? 

Is your laptop trying to do some sort of power saving?

Does the Fuze stay connected in MTP on a different PC?

IMHO, Auto Mode is a Bad Thing, because you never know how it is actually going to connect (and therefore which set of tracks is going to be visible to the PC).

Message Edited by daytona955 on 05-16-2009 08:03 AM

I had problems with MTP mode before. I would MSC mode if you can.

@smartinez281 wrote:

Recenly my 8GB Fuze had the dreaded white screen of death, so I sent it Sandisk to have a replacement shipped. The new fuze works fine but the major problem that I am having with it is adding music to it. Everytime i hook it up via usb, it reads normal for a while, but then it disconnects. For example I have it hooked in, and then after a few seconds, it acts like if i disconnected and then reconnected it again. It wont even charge. It does the same on MTP mode, but on MSC mode it works fine. On MTP mode in my device manger it lists sansa fuze but with the little yellow question mark next to it. I try to install drivers again, but the problem persists. Any ideas?

Make sure you ‘uninstall’, not just ‘disenable’ the device. Then un-plug from the computer and re-boot (the computer). Now, after it’s all started up and inititalized completely, then plug your Fuze back into it and see if it will re-install the correct drivers needed for MTP mode. These drivers are part & parcel of Windows Media Player 10 & 11. Some people have had better luck with one, rather than the other.

So if the uninstalling of the device in Device Manager doesn’t work, you might consider upgrading (or downgrading) your version of WMP to see if that makes a difference.

None of the above methods have worked. I tried to uninstall,downgrade,reinstall,restart on wmp and the drivers, but still nothing. any other suggestions?

 Try installing the MTP Porting Kit from Micro$oft. I don’t know what it does, but sometimes it helps the MTP connection.

Otherwise, maybe you should just give up on MTP and use MSC. The only reason to use Windows Media Player is with music that has DRM junk in it. Otherwise you can get every other function, like playlisting, with programs like Media Monkey or Winamp. 

the MTP kit did not fix my problem. I could just use MSC, but i really want to use MTP as well.

Also I get this error message after uninstalling the Fuze drivers,restarting, and trying to install them again

Message Edited by smartinez281 on 05-18-2009 08:57 AM

You also said when it’s not recognized it also does not charge…

If true that suggests that it’s not properly connected electrically.

Are you connecting it to the PC directly or maybe via a USB hub?  If a HUB, try connecting it directly without the HUB. Otherwise try it on another PC or a different USB port too.

Try and determine if it’s all PCs or something specific to yours.

Message Edited by timn on 05-18-2009 09:54 AM

The player works/recharges fine on all other PC’s in MTP or Auto Mode.

@smartinez281 wrote:
The player works/recharges fine on all other PC’s in MTP or Auto Mode.

That kinda narrows down the possibilities then, doesn’t it?

The problem isn’t with your Fuze, but something’s amiss with your PC. You aren’t running 64-bit XP or Vista, are you?

no and no.

Also It is a problem that recently started to happen. I have no idea what I did to make it not work properly. I think its because i uninstalled WM11 and went back to 10 for a bit (the rollback). But know i cant do the rollback anymore. This FUZE worked perfectly with this very laptop just a few days ago

Use the Device Manager to repair MSC, then MTP mode connections, after manually selecting each mode.

Uninstall the Sansa in each mode, unplug, and then reboot the PC.  Then plug in and let Windows reinstall.

Oh, and as you’re running Windows Me II (Vista), try the following quick Mode 10 Fixtoo.  Couldn’t hurt!  Remember, no spaces in the command “localservice”, that was a typo.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-18-2009 06:25 PM

Repair MSC? Im sorry but how would I go about in doing that?

Manually select MSC mode:

Settings > USB Mode > MSC. 

Plug in your Sansa.  It will establish an MSC (basic mode) connection.

Press [Windows Key] + [pause/break key] > Hardware tab > Device Manager.

Expand the Universal Serial Bus Controllers listing at the bottom.  Look for the wee yellow triangle of doom, if available, as it may flag the problematic device.

Now we can play hide-the-Sansa.  Well, at least Windows likes to do that.  Expand teh USB Root HUB listings that will show below, and select the Power tab. If you’ve located the Sansa’s port, it will show up here.

Then select the Driver Tab, and click on Uninstall.  You can now unplug yopur Sansa, reboot the PC, and then plug in again after it boots up.

Or, you can try the John Wayne method: select Update Driver.  Sometimes it works, but rebooting is safest.

Lastly, manually select MTP as above, and you’ll find the Sansa listed as a Portable Device.  Uninstall, then reboot, with the Sansa in MTP.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-18-2009 07:49 PM

ughh I tried both methods. Still no cigar. I uninstalled the USB thing in my device manager (to make sure it was the FUZE I went to properties and it said Sansa Fuze) and I uninstalled the MTP device, restarted, plugged in the player, but still no go.

I keep seeing this.

It’s listing under Portable Device, so we have an MTP issue.  Did you try right clicking on this list position, amd Update Driver or Uninstall?

Also, as it’s Vista, the Mode 10 fix is often key.  WiMP11 was welded in to Vista rather than acting as a plugin.  This makes repairing the “media center”, or whatever warm and fuzzy name they’ve given it, a royal pain.

Bob  :smileyvery-happy:

1st) Yes I have tried to Uninstall and Update driver.

2nd) I am using windows xp

You said you rolled back to WMP 10… Have you tried completely uninstalling WMP (regardless of version) and then Going to Windows website and Downloading WMP 10 and reinstalling it fresh? You could have a corruption in your installment. The other thing to try is to get a flash drive and plug it in, if it works then you should be able to use MSC mode, and if that doesnt work then I would manually Rollback the Firmware and re-upgrade. One thing nobody asked are you using a USB hub or expansions, or are the ports your using directly hooked to your motherboard? 

I tried to remove the WMP, still did not work. All my usb ports are working fine, as I had previously stated this MP3 player worked fine a few days ago. How can I manually rollback the firmware?

Go here, and do a manual Install. When I asked about USB Hubs or expansion slots, I was wondering if something could have come loose inside the PC (Its rare but possible). Did you try a flash drive (Not a Music Player) and see what reaction you got?