audiobooks won't play; show up as 'unknown'

Hi I just got a new 4GB Sansa Clip+ last week & so far I love it but I have one problem. I can’t get it to play any of my audiobooks. Most are in Audible format 4 and a few were ripped from CDs. None of them play. They show up in the Audiobook playlist as ‘unknown’ and when I click on it, the track name shows up as ‘unknown’ and won’t play at all. I also tried putting the Audible ones in the Audible folder & the same thing happens. Another weird thing is that if I go into Folders>Audible or Folders>Audiobooks, the track names show up but when I click to play them the name displays as ‘unknown’ & still won’t play. I’m running Leopard 10.5.7 and loading my clip by drag and drop for audiobooks & a m3u playlist script in iTunes for music. Any suggestions?

I’m not a MAC user but try this advice from the Clip+ user manual.  Since no one has helped you give this a shot - " For MAC be sure that USB mode is set to autodetect or MSC.

This passage deals with both Mac and Windows when files won’t show up. There’s more info in the full manual.

I’m having problems with Audible on Windows and I have a message in to Sandisk.  If I get a good answer I’ll post it on this list.  On mine the Chapter Mode doesn 't work

and the book parts must be manually changed rather than auto.

Donna in AR

  ![](file:///C:/Users/Donna/Documents/Web%20Capture%20Shots/Clip+%20Modes.png)

Thanks for the reply! I checked & the USB mode was set to autodetect. I switched it to MSC just to be sure. No dice on Audible files but I did get the ripped audiobooks to play. I’d really appreciate it if you updated me if you get a good response to your question :smiley:

I got a lengthy reply from Sandisk and am waiting on another reply.  You know it never occurred to me that Vista is not supported on either the old Clip

OR the new Clip+ at least on the box.  So far I’m loading OverDrive without a hitch BUT it is on an XP machine.  As soon as I hear will let you know.

Are you OK with Audible for MAC directions?  What format are you using?

My Audible books are in audible format 4 & have the .aa extension. I know these books work because I’ve played them on my old ipod nano. I sent an email to Audible yesterday & their response was:

“I understand that you cannot get the books to play on your Sansa Clip +. Unfortunately, while the Clip + is Audible ready, the Audible content would not be able to transfer to the Clip + using a Mac. The Mac is not configure with the plugin to transfer content to devices other than iPods and Palm devices. The technicians are working with Apple to hopefully create an application to make the transfer possible with different mp3 device, but no word has been made yet when and if it will be possible.”

I guess I’ll have to install windows on my laptop again to transfer them.  

Interesting that MAC settings are in the Clip+manual frequently. Again we are always talking music and audiobooks is treated as a stepchild as the MAC problem should have been covered.   I’m sorry it is such a headache for you.  Things ought to work as advertised but not in the world we live in.

I exchanged my Clip+ yesterday on the 30 day Best Buy plan because of a structural crack in the front of the player for another Clip+.  Today I’m going to see if it will

transfer an Audible book with things working properly.  I transferred one on my XP machine before I took the device back.  Neither Chapter Mode nor book part advancement

worked.  I’ll test the new machine one time today since Sandisk says the old device may have been corrupted (old story).  If it doesn’t work and I don’t believe it will

because the proper firmware was simply not put into this product, I’ll go back to my old clips and my 3G nano for Audible.  If you noted earlier someone wrote in that

rewinding is a current problem as well.  That’s why I think Audible won’t really work on the Clip+.  If a miracle happens, I’ll post to the list my findings

and my current good experiences with OverDrive and ripped books.  I do like the memory card for music.

Good luck with the dual boot!

Donna