Audio books filed in "Unknown" folder

I am on my 3rd Clip+ device and am having trouble with 2 books I downloaded today. I am using my clip with a MacPro and downloading books from Overdrive Media. I use the Finder to drag and drop files from the Documents folder to the Clip/Audiobooks folder. Ther are currently 5 books on the player. But when I check the player only 3 books are listed, along with a folder named “unknown.” The 2 books here are listed with alternating parts, so the books will not play sequentially although the other 3 play with no trouble, they are all mp3 files since that is the only kind Mac recognizes.

I have spent the last hour searching for answers and keep getting info about “tagging” the files. I have never had to do anything like that in the past with audiobooks and wouldn’t know where to start. I do have itunes but don’t know how to use it. Why would only some of the books do this?

And please, please, please, if you have a solution be explicit in explaining the solution. I googled how to tag and still don’t understand what it means or how to do it. I really don’t want to have to download a “fix” and have to use several programs to download and listen to a book, it really shouldn’t be that difficult.

It might be a Mac thing, I never had this trouble when I was using a PC and wma files.

What tags are is data added to the file that contail the album name, artist name, track number, etc. These are what your Sandisk player uses to sort files. If the tags are missing, or are in a format the player doesn’t support, then you get files listed as unknown and that are out of order. You can use itus to edit and fix the missing tags. The Clip+ needs mp3 tags in the ID3V2.3 ISO 8859-1 format. Some audiobooks already come tagged with this, but others may be missing the tags, or have them in an incompatible format(ie ID3V2.4) . In itunes you can see the tags and edit them. The Clip+ needs track numbers with leading zeros, ie. 001, 002, 010, etc. for 3 digit track numbers, or 01, 02, 09, 23, 33, etc. for 2 digit track numbers to sort properly.

If you drag and drop from a mac, you will also get index files begining with . that might make the player choke. You should use a program like Kopymac that will copy the files without the index files.

1 Like

If I recall correctly, Kopymac has “disappeared.”  However, Hidden Files provides the same functionality and people have said it works well (also freeware). 

to the OP:

I’m in the Windows realm, and sometimes use the Windows version of iTunes,  so I can’t give you absolute specifics about Mac. But maybe this can get you started:

Tags are electronic labels in the files. They display things like Album, Artist, etc. The player reads them and makes lists from them. If it can’t read them, or they’re not there, you get Unknown.

Most of the Audiobooks you’re getting probably have the tags put in them correctly. But someone has to put them in there in the first place. If they didn’t, for the books that are giving you trouble, then you have to do it.

With iTunes you can highlight a file and under File,  Get Info–which shows you the tags. Try it on one of your problem books and see what the tag info is. The Genre tag should be Audiobook–that’s how the Clip puts them in Audiobooks. See if anything else is obviously wrong, and change it.

The reason your books are alternating is that the Sansa is reading the Track Number tags. And both volumes probably have the same name (Book instead of Book Part 1 and Book Part 2) so the Sansa is playing both track 1s, then both track 2s, etc. The easy fix for that is to give the separate volumes different titles, like Book 1 and Book 2.

Using  Get Info in iTunes, you can change the same tag in multiple files by highlighting a bunch of them and typing the correct info into the box. But it’s pretty clumsy. 

Even if you don’t change anything, Save the tag. That could change the version of the tag and make it readable to the Sansa.

What that means is that through the years, the way the tags appear to the computer has been changing.  

Sansa players read ID3v2.2 and ID3v2.3 versions of the tags.  Newer tags may be in ID3v2.4, which will show up as unknown–and very old tags will be ID3v1, also unknown.   iTunes doesn’t give you any flexibility on tag versions, but older iTunes gives you ID3v2.2, which should work OK. I don’t know about iTunes 11, one of the most horrible pieces of garbage software in the known universe. For all I know it gives you ID3v2.4, useless for our little Sansas.

In my  Windows world, there is a great piece of free tagging software called mp3tag that lets you choose the version, change tags in bulk and automatically number them. But it’s not a Mac program.

I don’t know the Mac world at all but there should be taggers around.  Here’s one that turned up on Google, and it looks like they’ve been working on it for a decade, so it ought to be good. It  does change ID3 versions if needed.

http://kid3.sourceforge.net/

No, you shouldn’t have to do this. But Apple loves to make its own devices work easily and make you jump through hoops for anything else.

If you do find a good piece of tagging software, you should be able to give it the right settings (tag version ID3v2.3 ISO-8859-1, which is the Windows encoding the Sansa prefers) and just run each book you download through it–maybe 5-10 seconds per book. It’s an inconvenience, but a pretty minor one.

Maybe this is a silly question, but why don’t you use the “Transfer” function of Overdrive Media Console instead of drag and drop with the Finder? (I don’t have a Mac, but according to the documentation and online videos, the transfer function works the same on both Mac and Windows platforms). I’m pretty sure that this function uses the information in the tags to create the folder and file names on the player. I have never had any success with copying or dragging/dropping Overdrive audiobooks to a player on a Windows platform.

Well, duh. I missed the Overdrive part. Tapioca is right.

I have a clip and a clip+ and have the same problem decribed that just started a couple of weeks ago. When I use Overdrive transfer for a book it goes into an “unknown” location. If I look at the internal memory on the clip I see the folder, labeled correctly. However, on the clip screen it is only “unknown”. If I transfer another after that then it goes into the same “unknown” file but shows as a separate file if I look at the internal memory through my PC.  After reading the posts I downloaded mp3tag but now I don’t know how to use it. I know this may be basic for many but I need some assistance. Any help?

There are many how-to’s for MP3Tag online.  You might want to check them out–they should help walk you through.

http://www.bing.com/search?q=how+to+use+mp3tag&form=IE10TR&src=IE10TR&pc=MATBJS

As well as on-line help from the program’s creators on their website.

And there’s no shortage of discussions about it here on the forum either. Found easily using the Search function.  :wink:

Open mp3tag, find the book folder, highlight the files, and in the boxes on the left type into the Genre box: Audiobooks. And then Save. 

1 Like

Over the years Black-Rectangle has written the most comprehensive, complete and easy-to-understand tips and instructions for using MP3Tag I’ve seen on the forum (or anywhere, for that matter).

If anyone wants to learn about MP3Tag, use the Search function here and narrow your search to posts by him as the author. You will not be disappointed, and you’ll be editing your tags like a pro within minutes!

He should have a special designation as our resident MP3Tag Guru.

I hope it is OK to continue this forum a year later.  I also am having trouble getting the Sansa Clip+ to display the folder name of an Audiobook in the Audiobooks folder.  It insists on calling it “Unknown”.  I tried to use Mp3tag.  When I try to select that folder, I get a message from MP3tag “Folder name is not valid”.  The folder name is “Rendsburg - Genesis” which is similar to names of Audiobooks the Clip+ recognizes.  Any suggestions on what to do?  Thanks in advance.

Try using Mp3Tag and putting your folder name in the Album field on the left.

Remember, computers and especially players are stupid. All they can do is what people tell them. As I understand it, Audiobooks takes mp3 or wma files and reads their tags. But even though it’s a book, the template is still a music album, so the title of the book is like an album title.

Anyway, try it and let us know if that works.

OK, I put Rendsburg - Genesis in the Album field on the left in MP3tag and then tried to change directory to the subfolder of that name in the Audiosbooks folder on my Clip+.  I get the same message, “The folder name is not valid”.

OK, you’ve got me a little confused. 

Are you looking at the display on the player, or are you looking at the folders in your computer?

If on the player, are you navigating through Folders (way down the scroll in Music past Album, Artist, etc.)? Or through Audiobooks?  Audiobooks is navigating by tags. Folders should work like Windows Explorer, with folders and subfolders. 

The tags wil be (or should be) what the player displays. If Album doesn’t do it, try mp3tag for Artist (and make that the author). Make sure you are changing the tags in the copy on the player. Sometimes I have done a bunch of re-tagging only to find that I was changing the ones on my computer, not the player. D’oh. 

Mp3Tag won’t change the name of the folder in your computer. How about a folder name that’s just alphanumeric, no spaces, punctuation, etc. 

Thank you Black-Rectangle.  When I attach my Sansa to my computer, there is a path Computer\Sansa Clip+ 4GB\Internal Memory\Audiobooks shown in Windows Explorer.  The subfolders I am talking about are the next step down from this path.  When I play the Clip, I go to Music --> Audiobooks and then to the book in question.  The books are there on the Sansa display, usually with a name I can recognize, but sometimes several books are there bunched into a single designation “Unknown”.  I never use Folders under Music.  So my question is, I guess, is: How to I enter a useful name tag for a book using Mp3tag or Windows Explorer or whatever?.  As I mentioned before, when using MP3tag to try to point to the subfolder of Audiobooks, I get an error message.

I also posted on the MP3tag forum and got this reply: “You have to switch the player into a genuine USB mode. The MTP mode (which I think is now active) is not supported”.  So apparently he is saying it is not possible to edit tags on the Sansa Clip+ directly but must copy the file onto the PC and use MP3tag there.  Do you agree?

OK, I made some progress.  I switched my Clip+ to MSC mode and now in Mp3tag I can change the directory to L:\AUDIOBOOKS but can’t go deeper than that.  No information is displayed about the tags of the books in this directory.  So with this setup, how do I know I am only changing the tags for the Unknown book?

Short reply: It’s getting clearer. You need to take the Unknown books off the player, fix the tags on the computer and then send them back over.

Long explanation: 

At the moment, you can’t fix them directly on the player because you are connected to the player in MTP mode, which goes by way of sometimes mysterious processes using software built into Windows Media Player. If you got the audiobooks from your library, you may need to stay in MTP because Overdrive (the main library software) sends hidden codes–unlocking the files till they expire–via that Windows Media Player interface. MP3tag can’t get to those files because the WMP interface is in the way.

If you’re stuck using MTP, you should still be able to fix them on the computer and then send them to the Sansa. You just can’t fix them on the unit itself. 

Meanwhile, if you own these Audiobooks, you can switch the player (Settings/System Settings/USB) to MSC mode. This lets your computer see the Sansa as two regular old disc drives, and lets MP3tag work its magic. But before you switch, take the books off. Your computer can only see one mode at a time, MTP or MSC. The books sent over via MTP will be invisible when you switch to MSC. 

Unknown means the player can’t read the tags or they’re not there. Unfortunately tags are not completely standardized: there are lots of versions of ID3 tags. The Sansa can’t read ID3v1 or ID3v2.4–the oldest and newest tag versions.

So the tags might look fine to your computer, which is much smarter than the Sansa, and still come up Unknown on the unit.  

For some reason Sansa can only handle  ID3v2.2 and its favorite, ID3v2.3 ISO-8859-1  (The ISO is the way Windows, rather than Mac, renders the alphabet.) That’s why you set ID3v2.3 ISO-8859-1 as the default for MP3tag to Write.  

If you can put in ID3v2.3 tags, it’s probably easier to navigate via Audiobooks. 

Thanks.  I’m beginning too see what is going on. :manvery-happy:  When I switch to MSC mode, the reason I don’t see anything under the various columns in mp3tag, like Filename, Path, Tag, etc, is that all my books were loaded into the Sansa using MTP mode.  And, as you say, it is better to stay in that mode for the sake of the books you download using Overdrive.  For the present book, perhaps I shouldn’t take further action because it currently is the only one under the designation Unknown and it does play in order.  However, I would like to have your advice for the times in the future that I rip audiobooks on CDs to my computer and then download them to my clip.  If I use a tool like fre:ac to do the ripping, there is the opportunity to add information about the tracks like title, artist, album, etc.  I did not add anything for the Rendsburg - Genesis book.  I just created the subfolder of Audiobooks by that name, using Windows Explorer, and copied the tracks into it.  However, if I add the information about the tracks before transferring them, should I get proper tags that the Sansa Clip+ can read?

By the way, I have had the experience that sometimes Overdrive books are not properly tagged and end up in the Unknown folder.  Is it best before you do the transfer to check them with mp3tag?