PC link shows all audiobooks that I have loaded

disconnect from PC and they cant be found on Clip.


All Sansa players display infomation contained in the ID3 tags of the files, not the file names themselves. Obviously, your tags need editing.

I got this once by the way when I had a new clip. You need to edit it yourself.

Get mp3tag. http://www.mp3tag.de/en/ the free tag editor. If you’re on Apple you’ll have to find a tag editor. 

With mp3tag, when you install it, you can have it added to context menus (allow that). 

Run it and go to Tools/Options/Tags/Mpeg and make the Write option ID3v2.3 ISO-8859-1. Sansa likes those best. Make sure you save that change. 

When you download a book, right-click on the folder and you’ll have mp3tag as an option to open it.  Then you’ll see all the files listed in the folder. Highlight them all, make sure Genre is Audiobooks.

Make sure they are in playing order from top to bottom–you may have to click the Filename or Track headers–and then go to Tools/Auto-Numbering Wizard and choose the Leading Zeroes option. (This numbers them 01, 02, etc.) 

Also fill in whatever information is missing in the other fields. If those fields are empty, the Clip won’t display them.