Putting saved audioboooks into sansa clip+

First, I am very new at this, but I’ve searched the knowledge base and my question does come up, but it is always a part of the solution, and I don’t know how to do this.

I have saved my audiobooks to my computer over the years.  They are media player files (assuming mp3), but they do play on my husband’s ipod.  I’ve read and have been told that to get them on the clip I have to be sure the genre is audiobook.  What does that mean though?  I take those files and go to media player and click on genre, audiobook, and cannot get them in that folder.  (2 audiobooks from Audible are in there though.)

Yes, I can get the books into media player, and from there into the clip, but just like when we tried it with the ipod, the book files are scattered throughout the music files.   My goal is to get the books all into the audiobook folder in media player and on the clip.

Thank you

Open Windows Media Player (if that’s what you’re using), go to the folder and highlight all the files. Right-click on the bunch of files and choose Advanced Tag Editor. There’s a Genre field on the right. Type Audiobooks in there and save it. 

The tags tell the Clip+ how to organize your files. (That’s where you get Album, Artist, etc.)  When it sees Audiobooks in Genre it separates them from the other mp3 files. If it doesn’t see Audiobooks, it thinks they are music. 

Hope this doesn’t get lost since my software and problem are different, but similar. I have succesfully played a downloaded mp3 audiobook moved to the Audiobooks folder. But I have downloaded Audible book files (Filename.aa), and they won’t play in either Audible folder or Audiobooks folder. In another thread, microsansa said that the Clip+ supports the .aa format. How, please, someone? FWIW, the files were duplicated with the extension .pos.

It’s been awhile since I used Audible, but did you transfer the Audible files to your Clip+ using the Audible transfer software?  I’m thinking that the files did not transfer over as they should or that the necessary licenses did not transfer with them.  The Clip+ indeed will play Audible files.

There is currently no Audible Mac file manager; they say just use iTunes (which I did), but I haven’t yet discovered if there is some way to use iTunes to get the DRM files to the Clip (doesn’t seem likely).

Oh, gee, thanks so much, Crescendo.  This really did answer my question, and though I’ve tried saving only one file, I’m sure your instructions are exactly what everyone meant when they told me to save to the Genre of Audiobooks in media player (though it won’t go in the audiobooks already there by default).

Another odd thing, and that I am not so concerned about though it is a real pain.  I am now finding that many of the books I’ve saved over the years and not looked at since, and those I just tried saving, are saving in the oddest ways.  Here is an example:

I copied my copy of The Shawshank Redemption to media player.  Disk one saved itself as Stephen King in Alternative.  Disk two saved itself as _ Frank Muller, the reader, in Soundtracks _…ad infinitum. I then looked at others and found many missing disks, or files.  After seeing how Shawshank got saved, I started searching and have been finding them saved in the same odd way: one disk in New Age, 3 disks in Alternative, 1 in music, another in soundtracks.  

I will redo these old saves if I cannot just move them where they belong so I can then transfer it all to my sansa.  At least now I will know how to set the genre.

Bonnie

Hmm…Hamdenite, this is one thing I had no problem with…phew.  I replied to an audible offer of free downloads.  Of course, with it came Audible manager and that is where the free books went.  From there I was very very easily able to transfer the files to my clip, and they actually stayed together in the default audiobooks file.

Your manager is some MS Windows product, I believe; I’m using Mac, which people think works, but have not yet explained how.

Oh, I am sorry, I can’t help you either.  Don’t know a thing about MACs.  Maybe if you started another thread with your issue in the subject line more folks would see it.  Good luck.  This stuff can be so frustrating!

Bonnie–

You could either fix what you’ve got, or you could re-rip. 

A little explanation…

The Sansas (and most other mp3 players) arrange the music by reading the ID3 tags. When you look at Songs, the Sansa lists Titles from that ID3 tag. Same with Genres. It did establish the Audiobooks folder so you could keep books separate from music, but that’s unusual–most everything else is from the ID3 tags.

So the ID3 tags have to be the right ones.

Your problem is that whatever underpaid human originally put the tags on the files made some strange choices. And then, to make things worse, Windows Media Player made separate folders apparently based on the Artist tag, with subfolders based on Album.

This would be fine if the Artist was Rolling Stones and subfolders were Let It Bleed, Beggars Banquet, etc. But when someone at the audiobook company decides the artist is whoever is reading the book, well…

To re-rip, insert the CD in Windows Media Player and let it get tags (online) and then fix the tags you see–make sure Album is the book title, make sure Artist is the author, make sure genre is Audiobooks (you’ve heard that one before). No wacky stuff. Then have it rip after you’ve adjusted the tags, and you’ll have the tags you want. 

Or if you no longer have the CDs or feel like fixing what you already have,  there is a great piece of free software for fixing tags. It’s http://www.mp3tag.de/en/

It’s a lot easier to use and smarter than the Advanced Tag Editor in Windows Media Player. When you install it, there’s an option to add it to Context Menus–check that. 

After it’s installed, open it and make it write the tags the Sansa likes: Under Tools/Options/Tags/Mpeg choose Write and ID3v2.3 and ISO-8859-1. OK it, and you won’t have to touch that again. 

I’m hoping that your messed-up audiobooks have filenames in track order. 01-Chapter 1, 02-Chapter 2, etc. If you can gather all the scattered chapters and put them inside one big folder–just drag the subfolders in there–you can right-click on the big folder and choose mp3tag, which will list all the files in and out of subfolders. Hopefully in order if the filenames are numbered. 

Once they are in order–you can move them up and down in the list if you have to–highlight them all, choose Album, Artist, Title, etc on the left in a way that makes sense to you, and (under File) save them. Then do one more thing: under Tools is something called Auto-Numbering Wizard. Pick Leading Zeros to make Track numbers (the order the Clip plays them)  01, 02, 03, again so the Sansa can handle them. It doesn’t like track numbers like 1/18, 2/18, etc.

You could do similar things in Advanced Tag Editor, but mp3tag works faster and easier.Even if you rip with Windows Media Player, open the folder afterward with mp3tag and run the Auto-Numbering Wizard just for luck. 

Message Edited by Crescendo on 12-21-2009 02:09 PM

Holy Mackeral, Crescendo, I can’t believe you took all this time to write such a thoughtout reply.  This is so helpful, and so very much appreciated.  I am going to print out your response so I can work off of it while I do exactly what you suggest.  Will download that program.  Thank you so very much.

Bonnie

If you are windows user get off Windows Media Player and start using Media Monkey.

It’s free (there is a pro version $ but free will work great).

It has very powerful tagging tools that let you look up music against Amazon’s (and others’) DB for fast tagging.

Genre is excluded but you can do genre lookup with easy to get plugin, and overall the monkey is very good player

For Apple users I’m not sure the Sansa Clip is a really good match (perhaps other know better?)
I was thinking of getting one for my folks (mac users) and I searched online for simple ways to manage/upload music but I read so many tecchie hoop-jumping stories I thought better of it.

M

Just my two-cents . . . when I prepare tags Audiobooks for my Clip+, I put the “book title” in the “artist” tag slot, and the “author” in the “album” slot.

The Clip+ only displays “artist” and “title” on the small screen - I prefer to see the book title on the screen.

You’ll get the author displayed if you do it the correct way, like you’d do it for music.  Just a little work-around I use.

Also a question - - When I edit or prepare my tags, “Audiobook” isn’t on the pull-down menu for “genre”. So, as everyone says, I just type “Audiobook” in the “genre” slot. My simple question is: does it make any difference if you type “audiobook”, “audiobooks”, “Audiobook”, or “Audiobooks”. I haven’t found that either one makes a difference.

I do put all my audiobooks in the “Audiobook” folder . . . .

Love my CLIPP+ ! 

Early on with the original Clip, I found that if I used the word Audiobooks or Podcasts (plural), the Clip didn’t like it–the singular form worked instead.  That may have changed over time, from what you report.

I’ve received word from Audible by e-mail that I can use the Windows Manager once to “register” the Clip+, presumaby using username and password to install some files for DRM. After that my .aa Audible files installed there via Mac Finder should play OK. Haven’t tested this - no handy access to Win computer. May try library, but they should be protected from downloads.

@TunaCan

No it makes no difference (in my experience)

If you put them into the audiobook folder then it works fine.

@BonnieSZ

I’m not sure how you are managing your music library Bonnie, but I assuem you have software that you feel comfortable with to do this.

To refine my previous repy, I like MediaMonkey because of its fairly smart ID3 tag management.

With Audiobooks I tend to do the following:

Rip

mp3 with CDEx (free)

1 CD = 1 MP3 file   (Moby **bleep** disc 1 = Melville.MobyDick.01.mp3)

ID3 Tag Set

MediaMonkey (Free)

Select All X MP3 files

Set same for all X files (CDs)

Title

Artist

Genre

Album Art (using Amazon script)

Reset Tracks Automatically 01-15 or whatever (Auto-increment Tag script from MediaMonkey)

This ensures proper play order in Clip

Reset File Titles to Moby **bleep** 01, 02, 03

This helps me figure out what CD I’m on in Clip

I found the method above to be the most efficient for managing large numbers of audiobooks and also simplifying playback in the Clip.

Some folks rip Books track by track but the Clip seems good enough at bookmarking that I found no need for tracks.

Some folks rip entire Books (many CDs) to one big MP3 but I found this a bit too massive, as I like to delete say… CDs 1-8 off Clip and leave 9-15 on there to keep listening, so as to make room for podcasts and other things

Hope this helps.

Oops sorry for choosing a bad book title, I really do read Melville!

Message Edited by emagin on 12-27-2009 02:23 PM

emagin, thanks so much.  I am new to the clip, ipods and saving music.  Wasn’t really interested until I started listening to audiobooks and began saving them for my husband on his ipod.  What a mess with everything mixed in with his music.  (As I’ve already said so I won’t repeat.)  And I was having the same messes with this clip.  While I am behind in this music technology, I will learn quickly if everything is spelled out for me, in detail, with no steps left to assumption that I know what you are talking about.

Now, spelling everything out step by detailed step is a pain, I know, and takes a long time.  So, with that in mind, I thank you from the bottom of my heart and frazzled brain.

(My clip was such a mess that I printed out all of the replies and decided to delete everything but the Danny Boy song that came with the clip and start over.  I also noticed that many, many, tracks are missing from the audios I copied to itunes and then sent to media player.  I’ve searched all through my music, but they are gone.  Not a huge deal for the books I still have the originals for…but some I’ve given far far away…)