Audiobook won't play!

OK, back again! I will first apologize in that I haven’t spent time researching on the board to see if this has been addressed. Pressed for time.

I went to rewind Mom’s book as she fell asleep. Weird happenings. Went to the book and found she had finished it. I went backwards and it was acting OK. Then all of a sudden it wouldn’t move(no numbers are moving forward or even backwards) or even play. Yet in the bottom it is saying now playing. I tried another book and the same thing. Then I tried the first book and when I went to it the message came up: resume or start from beginning and it reverted to the other book! Lastly I had just loaded a new book so I tried that one. While the title and the cover of the book is displayed, another book information is displayed next to it! No numbers are moving forward, nothing. Unfortunately I don’t have any music yet loaded on hers so I don’t know what the issue is to further explore.

Some basic facts: Sansa Fuze 4GB, most current firmware has been loaded, everything had been perfectly normal. I think Mom may be right, electronics do not like her!

Is this fixable? Reformat? This is a new one on me.

When I get some free time I will do my “research,” but wanted to throw it out to all in the meantime.

Thanks as always for any input!

Well, this is one way to solve. The player completely froze. Like a good person I quickly checked for a solution and saw if I held the power for 20 seconds it would do a soft reset. I now know what this means! It totally wipes out everything. Fortunately the book was still in my download so I could recover it. It also seemed to fix the problem with the book or for now it did. I’m not going to load the other books back until this one is finished, so won’t know if there is still a problem.

Was the frozen step the next part of the problem and the other issues just leading to it? Could the last book loaded have some virus or something? Just curious?

Shawney59 wrote:

. . . if I held the power for 20 seconds it would do a soft reset. I now know what this means! It totally wipes out everything.


No it doesn’t. That’s what a format does. A reset simply . . . well, resets the player if it gets caught up or stuck on something. Hence the name.

OK. I stand corrected! That was what I thought it meant. Then please explain why when I turned it back on my books where all gone. I did absolutely nothing else.